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1. Introduction 

1. Foreword 
French law n° 2005-102, of 11 February 2005, for equality of rights and opportunities, participation and 

citizenship of people with disabilities, makes accessibility a requirement for all public online communication 

services, for the State, local and regional authorities and the public institutions that depend on them. 

The RGAA (General Accessibility Framework for Administrations) aims to promote accessibility of the 

contents available in digital form. In 2014, the RGAA was redesigned to be up-to-date and more operational. 

The French administrations currently ought to refer to the RGAA 3. 

To meet the needs of diverse groups and contexts, three levels of compliance have been defined: A (lowest), 

AA and AAA. The level legally expected is level double-A (AA). Success criteria associated with the AAA 

level may be taken into account in certain contexts where possible and relevant. 

2. The RGAA and office documents 
The RGAA applies to any document or application available online: websites, Intranet and web applications, 

but also the contents downloadable as separate files. 

In the Consultation category of the RGAA, criterion 13.71 (Level A) states that "each office document that 

can be downloaded [must] have an accessible version if necessary". Compliance with this criterion can be 

achieved in particular by providing an accessible HTML version or by making the document accessible in 

the format proposed for download. 

This companion guide presents the considerations and principles for creating an accessible document with 

Adobe Acrobat Pro Document Cloud, along with non-normative guidance and procedures for implementing 

them. Each chapter is divided into topics and incorporates a reference to the corresponding RGAA criteria. 

3. Who is this guide for? 
These guides are intended for all professionals in government departments, local authorities, agencies, public 

institutions, public enterprises or anyone wishing to: 

• Produce accessible office documents; 

• Improve the accessibility of existing office documents; 

• Test the level of accessibility of office documents already created. 

4. Technical devices used to access content 
A document is accessible if it can be accessed by any user, regardless of the computer tool being used. More 

and more users are using assistive technologies to overcome barriers to accessing office documents or web 

content. These technical solutions include 

• Software assistive technologies (screen readers, voice recognition / dictation software, etc.); 

• Hardware assistive technologies (adapted mice, trackballs, Braille displays, etc.). 

Content and applications must be compatible with these various assistive technologies, their functionalities 

and uses. 

5. About this translation 
The original document, in French, refers to Adobe Acrobat Pro Document Cloud in the version available at 

the time of writing (February 2016). At the time of translation (August 2017), the current release (2017) may 

show slight variations. This translation takes this fact into account and is based on the features of the 2017 

release where applicable. 

                                                 
1 URL: https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7 

https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7
https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7


5 

6. Conventions 
This document indicates keyboard shortcuts for commands used in Adobe Acrobat Pro Document Cloud. In 

the Windows operating systems family, the CTRL (Control) key is used as a modifier for many shortcuts. In 

the MacOS system, the equivalent modifier key is CMD (Command, represented by the ⌘ symbol). In the 

rest of this document, for clarity, only the Windows shortcut (with CTRL) will be mentioned. Mac users are 

invited to replace it with CMD. 

Texts in bold generally refer to commands and menus available in the user interface. Indications like “File > 

Save” must be understood as “Open the File menu, and then select the Save item in this menu”. 

Mentions like “Right-click on...” actually refer to opening a contextual menu, associated with an item. On 

most systems, this is usually done by clicking on the item with the right button of a mouse or a trackpad. 

Another method, on Windows, consists in pressing the “Menu” key on the keyboard. On MacOS based 

systems, pressing the CTRL key and the left button simultaneously has the same effect. Unfortunately, there 

is no easy way to activate a contextual menu through a keyboard on a Mac. 
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2. Getting familiar with PDF and Adobe Acrobat Pro DC 

1. PDF and assistive technologies 
Portable Document Format (PDF) is a format developed by Adobe Systems. It preserves the formatting as 

the author defined it, regardless of the application or the platform used to read it. 

PDF tags reflect the structure of the document. A tag tree represents the organizational structure of the 

document and allows assistive technologies to determine the order, presentation and interpretation of its 

content. The relationship between the various elements of the document and the properties associated with 

these elements (for example, replacement text for images conveying information) must be defined in this 

tree. 

2. Creating accessible PDF documents with office applications 
In most cases, creating PDF files from a document made accessible in an authoring application (Microsoft 

Word, LibreOffice Writer, etc.) leads to better accessibility than a full rework in Acrobat downstream. By 

creating PDF documents from structured office documents, the total time required to mark up the document 

will be considerably reduced. For this reason and as far as possible, it is preferable to return to the source 

file, to structure it, and improve its accessibility with the original authoring application. 

Tagging is the first condition of accessibility. Adding tags can be done automatically when exporting the 

document to PDF in the authoring application if you check the markup option for accessibility. For more 

information on creating accessible desktop documents, see our other guides for different authoring 

applications (LibreOffice 5.2 and Microsoft Office 2016). 

If a properly structured document in an authoring application will benefit from better accessibility when 

exported in PDF format, it is necessary to verify that the document has been properly marked up 

automatically. Assessment work, and possible corrections of loss of information or conversion errors, with 

Adobe Acrobat Pro, are required. 

3. Visualizing the PDF document structure 
Creating an accessible PDF document involves giving it a structure and a reading order that can be used by 

assistive technologies. A PDF document can be interpreted in 3 ways: 

• Visually: the visual order in which sighted readers scan a document 

• Structurally (tags): the order in which assistive technologies scan the document 

• Reflow Order: The order used by Adobe to feed the "Reflow" or "Audio Playback" options. 

While the three visions of the document must logically match, this is not always the case. Only the structural 

order, that is, the tags, reflects the true structure of the document. The tags identify the contents of the PDF 

(document title, chapters, sections, headings, lists, etc.), define a reading order, and facilitate navigation in 

the document. PDF tags exist only for accessibility purposes and have no visible effect on the PDF file. 

 

4. Main tools to work on the accessibility of a PDF document 
The latest versions of Adobe Acrobat Pro DC provide an Accessibility action to guide the user through the 

steps necessary to make a PDF file accessible. The tool allows you to quickly populate certain properties 

(title, subject, language, etc.), assign replacement texts to images conveying information, and tag form fields. 

Although this tool can save time for a number of steps, it does not guarantee and verify the quality of the 

generated markup. For this reason, this tool will not be covered in this guide. 

Tool Used to 

 

• Tag form fields 

• Assign a replacement text to  illustrations 

• Fix simple tables 

• Remove any superfluous (decorative) content from the tree 
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Tool Used to 

Tags panel 

• Correctly tag complex tables 

• Tag paragraphs, lists and sections using different languages 

• Remove obsolete tags 

• Add replacement texts to links 

Content panel 

• Modify the reading order of some objects in the page 

Order panel 

• Deprecated because it can cause a visual overlap of page elements 

 

The Tags panel is the most important tool to work with the accessibility of a PDF document because it allows 

you to view, add, or edit tags in the document tree accurately. This tag tree reflects the order in which the 

document is read by assistive technologies and contains all of the elements of which the document is 

composed. 

 

Caution! 

The manipulation of the structure of the PDF file via the three tools introduced above presents a significant 

risk of damaging the file, because the operations performed are irreversible (the Cancel feature is not 

available). Therefore, you should consider saving a backup copy before you begin working on the 

accessibility of the PDF file, and creating a new version before each new tagging step. 

1. The Touch Up Reading Order tool 

To open the Touch Up Reading Order tool: 

1. Go to Tools > Accessibility. 

2. In the tools list displayed, select Reading Order. 
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1. The Tags panel 

To view the Tags panel, select View > Show/Hide > Navigation panes > Tags. 
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To locate the contents in the tree, highlight the content in the view pane and in the Tags navigation panel 

select the Find Tag From Selection option. The tag corresponding to the selection is then opened and 

selected. 

2. The Content panel 

The Content panel shows a global view of the content objects, tagged and untagged, that compose the PDF 

document, organized according to their display order. 

To view the Content panel: 

1. Select View > Show/Hide > Navigation panes > Content. 

2. Develop the document name to view the pages and objects it is composed of. 
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Note: The contents in one or more containers bearing the same name as tag names, are tagged. Contents 

directly at the document root are non-tagged contents. 
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3. Evaluating the complexity of a PDF document 
Note: The contents in one or more containers bearing the same name as tag names, are tagged. Contents 

directly at the document root are non-tagged contents. 

Before starting to work on the accessibility of the PDF document, it is necessary to analyze the contents of 

the document in order to assess their complexity. Understanding the characteristics of the document, and 

what types of barriers to access can result from them, it is possible to know which tools to deploy, and which 

techniques to apply to solve these problems, while estimating the time needed to make the document 

accessible. The more complex the document, the longer it will take to produce an accessible document. 

As a first step, it is necessary to verify the presence of tags in the PDF document: 

1. Go to View > Show / Hide> Navigation Panes > Tags. 

2. If tags are present, the tree view is displayed in the navigation pane that appears on the left side of 

the screen. If there is no tag, "No Tags available" is displayed. 

If no tag is present, you must tag the document first. 
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1. Tagging an untagged PDF document 
Tagging allows to identify and structure all the contents presented in a PDF document, in order to make them 

accessible and understandable to  assistive technologies. 

The first element of the tree is the tags root, which is the parent of all the other tags. Structural elements 

(articles, sections, parts, etc.) are listed as containers (parent tags) and may include several child tags (lists, 

illustrations, tables, etc.). 

The PDF tags scheme is not restricted, but to ensure a correct interpretation of the contents, the use of 

standard tags is necessary. The list of the most frequently used PDF tags is given in the Main tags used 

appendix. 

1. Automatic tagging of a simple non-tagged document 
Adobe Acrobat provides a feature to automatically tag non-tagged documents. Applied to simple documents 

composed mainly of text and images, this feature can save time. However, for more complex documents, the 

generated markup is not of very good quality and a manual correction can be a waste of time. In these cases, 

manual tagging from the start should be preferred. 

To tag a simple, non-tagged PDF document automatically: 

1. Go to Tools > Accessibility > Autotag Document. 

 

 

2. A “Recognition report” is displayed in a panel on the left side of the screen. The report indicates the 

elements in the document that may not be correctly tagged. This report is temporary and can’t be 

saved nor reloaded. 
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The recognition report is a good starting point for identifying and correcting markup errors, but further 

manual analysis is required to ensure that the entire markup is representative of the content presented in the 

PDF document. In addition, some content may be assigned erroneous tags that clutter the tree and alter the 

reading order. 
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1. Manuel tagging of a complex non-tagged document 
In order to ensure that the structure and reading order of complex document elements are correctly 

interpreted, and avoid rendering issues by assistive technologies, manual markup should be performed 

according to the techniques described in this guide, using tools provided by Adobe Acrobat Pro. 

1. Creating the tags root 

Before you start creating tags, you must create a tag root of tags that is the parent of all the tags in the 

document. To create the root: 

1. In the Tags navigation pane, select No Tags available. 

2. Right-click and select Create Tags Root. 

 

2. Creating empty tags 

Before starting  to tag, it is important to be aware of the different contents as well as the list of the different 

types of tags available (see Main tags used). 

To create an empty tag: 

1. In the Tags navigation pane, select the parent node in the tree view (the icon that is at the same level 

as the child tag you want to create). 

2. In the Options local menu, click New Tag. 

3. Select the desired tag type from the list. 
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4. If you it helps, give a title to the tag to identify it more easily in the tag tree (this title will not be read 

by assistive technologies). 

5. Click OK. 

When a tag is selected in the tree, the created tag is added after the selected tag. If no tag is selected, the new 

tag is added to the end of the tree. 

3. Inserting content in a tag 

To add content to an empty tag: 

1. In the Tags navigation pane, select the tag. 

2. In the View pane, click on the Selection icon in the toolbar, and select the text or object you want to 

tag 

 

 

3. In the Tags navigation pane, right-click on the empty tag and select Create Tag from Selection (this 

actually means that the tag will be filled with the selected content). 

 

4. Moving a tag 

To move a tag: 

1. Open the tags root in order to display the whole tree. 

2. Select the tag icon of the element you want to move. 

3. Drag the tag and drop it into the desired location (a line is displayed to show possible locations). 
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5. Modifying a tag 

To change the type of tag: 

1. Open the branch of the tree you want to modify. 

2. Select the element, then go to Options > Properties 

3. Choose a new type of element in the Type drop-down list, then click on Close. 

6. Deleting a tag 

To delete a tag: 

1. Select the tag you want to remove. 

2. In the Tags navigation pane, select Options > Delete Tag. 
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When a tag is deleted, its content remains visible in the document, but will not be read by screen readers. 

7. Defining a global tags structure 

When all tags in the document are created and assigned to content, it is recommended, for very long or very 

complex documents, to use the <Part> tag to organize tags in pages or chapters containing multiple pages. 

These tags will be used to provide a global structure for the document, but can also be used to create 

bookmarks that allow users to navigate through the document structure via the Bookmarks panel (see 

Bookmarks). The elements composing the part must be positioned as its children in the tags tree. 

This solution is only recommended for long or complex documents, because creating and manipulating tags 

manually can lead to errors. For most documents, defining heading tags (<H1>, <H2>, etc.) is sufficient to 

ensure correct navigation. 
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5. Fixing a tagged document 
When a PDF document is generated from a text editor or other document authoring software, the generated 

tags do not always have names that are consistent with those provided by Adobe Acrobat (you can find 

<Contents 1> instead of <P> for paragraphs, for example). 

Adobe Acrobat Pro DC provides a tool for defining the Adobe mappings of non-standard tags via a role 

mapping table. 

To map roles: 

1. Open the Tag navigation panel. 

2. In the Options, select Edit Role Map. 

3. In the Role Map dialog box, open the document tags root and verify that the proposed mapping is 

correct. To fix a mapping, select the item from the list and click the Change Item button. Type the 

name of the corresponding Adobe tag (see Main tags used) and click OK. 
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6. Giving an alternative to non-textual elements 
1. Applicable RGAA criteria 

 

Category criteria 

Images 

Criterion 1.1 [A] Does each image have a text alternative? 

Criterion 1.2 [A] For each decorative image with a text alternative, is this alternative 

empty? 

Criterion 1.3 [A] For each image conveying information with a text alternative, is this 

alternative relevant (except in particular cases)? 

Criterion 1.6 [A] Does each image conveying information have a detailed description if 

necessary? 

Criterion 1.7 [A] For each image conveying information with a detailed description, is this 

description relevant? 

Criterion 1.8 [AA] When an alternate mechanism is missing, each image of text conveying 

information must be replaced with styled text, if possible. Has this rule been followed 

(except in particular cases)? 

Criterion 1.9 [AAA] Each image of text conveying information must be replaced with 

styled text. Has this rule been followed (except in particular cases)? 

Criterion 1.10 [A] Is each image caption correctly associated with the corresponding 

image, if necessary? 

Colors 

Criterion 3.1 [A] On each Web page, information must not  be conveyed through color 

only. Has this rule been followed? 

Criterion 3.2 [A] On each Web page, information   must not be conveyed through color 

only. Has this rule been implemented in a relevant way? 

Criterion 3.3 [AA] On each Web page, is the contrast between the text and background 

colors sufficient (except in particular cases)? 

Criterion 3.4 [AAA] On each Web page, is the contrast between the text and background 

colors enhanced (except in particular cases)? 

Links 

Criterion 6.1 [A] Is each link explicit (except in particular cases)? 

Criterion 6.2 [A] For each link with a link title, is this title relevant? 

Criterion 6.3 [AAA] Is each link text alone explicit out of context (except in particular 

cases)? 

Criterion 6.4 [A] For each web page, does each identical link have the same purpose and 

target? 

Criterion 6.5 [A] On each Web page, does each link, except in anchors, have a text? 

Consultation 

Criterion 13.11 [A] On each Web page, does each cryptic content (ASCII art, emoticon, 

leetspeak) have an alternative? 

Criterion 13.12 [A] On each Web page, for each cryptic content (ASCII art, emoticon, 

leetspeak) with an alternative, is this alternative relevant? 
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Criterion 13.15 [A] On each Web page, are sudden changes in luminosity or flashing 

effects used appropriately? 

Criterion 13.16 [AAA] On each Web page, do the sudden changes in luminosity or 

flashing effects have a frequency lower than or equal to 3 per second? 

Criterion 13.17 [A] On each Web page, can each moving or blinking content be controlled 

by the user? 

Multimedia 

Criterion 4.1 [A] Does each prerecorded time-based media have a text transcript or an 

audio description if necessary (except in particular cases)? 

Criterion 4.2 [A] For each prerecorded time-based media with a text transcript or a 

synchronized audio description, are these relevant (except in particular cases)? 

Criterion 4.3 [A] Does each prerecorded synchronized time-based media have 

synchronized captions if necessary (except in particular cases)? 

Criterion 4.4 [A] For each prerecorded synchronized time-based media with synchronized 

captions, are these captions relevant? 

Criterion 4.5 [AA] Does each live time-based media have synchronized captions or a text 

transcript if necessary (except in particular cases)? 

Criterion 4.6 [AA] Are each synchronized captions or text transcript, provided for live 

time-based media, relevant? 

Criterion 4.7 [AA] Does each prerecorded time-based media have a synchronized audio 

description if necessary (except in particular cases)? 

Criterion 4.8 [AA] For each prerecorded time-based media with a synchronized audio 

description, is this audio description relevant? 

Criterion 4.9 [AAA] Does each prerecorded time-based media have a sign language 

interpretation (except in particular cases) if necessary? 

Criterion 4.10 [AAA] For each prerecorded time-based media with a sign language 

interpretation, is this interpretation relevant? 

Criterion 4.11 [AAA] Does each prerecorded time-based media have a synchronized 

extended audio description if necessary (except in particular cases)? 

Criterion 4.12 [AAA] For each prerecorded time-based media with a synchronized 

extended audio description, is this audio description relevant? 

Criterion 4.13 [AAA] Does each synchronized or video-only time-based media have a text 

transcript (except in particular cases)? 

Criterion 4.14 [AAA] For each synchronized or video-only time-based media with a text 

transcript, is this text transcript relevant? 

Criterion 4.15 [A] Can each time-based media be clearly identified (except in particular 

cases)? 

Criterion 4.16 [A] Does each non time-based media have, if necessary, an alternative 

(except in particular cases)? 

Criterion 4.17 [A] For each non time-based media with an alternative, is this alternative 

relevant? 
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Criterion 4.18 [A] Can each autoplaying sound be controlled by the user? 

Criterion 4.19 [AAA] For each prerecorded audio-only time-based media, are the 

dialogues audible enough (except in particular cases)? 

Criterion 4.20 [A] Can each time-based media be, if necessary, controlled either through a 

keyboard or a mouse? 

Criterion 4.21 [A] Can each non time-based media be controlled either through a keyboard 

or a mouse? 

Criterion 4.22 [A] Is each time-based media and each non time-based media compatible 

with assistive technologies (except in particular cases)? 

2. Introduction 
Non-textual elements are becoming increasingly important in office documents. Photos, maps, graphics and 

mathematical formulas enrich documents and convey information to readers. 

For non-textual elements that convey information not presented as text in their proximity, this information 

must be described in a replacement text. Without proper description, these elements can't be perceived by 

assistive technologies, that will signal the presence of a graphic element without any other information. 

Adobe Acrobat Pro includes tools to create a replacement text that will be returned to the reader by assistive 

technologies. 

3. Images and charts 
You should ask yourself 3 questions before choosing the text that will be rendered in place of the image: 

• Is the image purely decorative, not conveying any information and having no function? 

• Does the item convey information? 

• Does the image have a function (for example, a picture serving as a link)? 

If the image is purely decorative, this must be explicitly mentioned, in order to avoid it being rendered by 

screen readers. 

To mark an image as decorative, and remove it from the tags tree: 

1. Open the Touch Up Reading Order tool. 

2. Check that the Show page content groups and Show tables and figures options are selected. 

3. Draw a rectangle around the image that must be marked as decorative. 

4. In the Touch Up Reading Order dialog box, click on Background. 
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If the image conveys information, it must be tagged as <Figure> and be associated with a replacement text. 

This alternative, which also serves as a title, must succinctly describe the information conveyed by the image 

and its meaning in the context. 

For an image that serves as a hyperlink, the replacement text must help the user understand the function and 

the destination of the link. The conditions for returning this replacement text require that it be as short as 

possible (a maximum length of 80 characters is strongly recommended). 

A replacement text should not: 

• Duplicate information in the caption; 



23 

• Include copyright information (for example, for a photo, the name of the copyright holder and the 

date of the picture) 

• Start with "picture of..." or "photo of...". 

If it’s not already the case, follow these steps to tag the image as a <Figure>: 

1. Open the Touch Up Reading Order tool. 

2. Draw a rectangle around the image conveying information. 

3. In the Touch Up Reading Order dialog box, click on Figure (this command assigns a <Figure> tag 

to the image). If the image is associated with a caption, draw the rectangle around the illustration and 

the caption simultaneously, and click the Figure / Caption button (this command assigns a <Figure> 

tag that contains the image and a < Caption> tag which contains the caption itself). 
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To associate 

an alternate 

text to the 

image: 

1. In 

the View 

pane, 

right-

click on 

the 

image, 

then 

select 

Edit 

Alternate Text… 

2. Enter an alternate text and click OK. 

If an alternate text is assigned to text elements, only the alternate text will be read by assistive 

technologies. 

4. Mathematical formulas 
Adobe Acrobat Pro provides a tag to describe a formatting specific to mathematical formulas: <formula>. To 

designate a text as a mathematical formula: 

1. Open the Touch Up Reading Order tool. 
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2. Draw a rectangle around the formula. 

3. In the Touch Up Reading Order dialog box, click on Formula. 

 

Adobe Acrobat 

does not support 

the MathML 

format correctly. 

It is 

necessary to write the formula "in full", as it would be pronounced by a vocal synthesis. For example: "sum 

of 1 to n of x squared". See this article on Equations in PDF on WebAccessibility.com2. 

                                                 
2https://www.webaccessibility.com/best_practices.php?technology_platform_id=57 

https://www.webaccessibility.com/best_practices.php?technology_platform_id=57
https://www.webaccessibility.com/best_practices.php?technology_platform_id=57
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5. Multimedia files 
Adobe Acrobat Pro Document Cloud supports the MP3, MOV and SWF formats, but the FLV and FV4 

formats are not supported anymore. 

To insert a multimedia file in a PDF document: 

1. Go to Tools > Rich Media, then click on the Add Sound, Add SWF, or Add Video button. 

 

 

2. Draw an area in the page with the mouse. The multimedia file will be inserted there. 

3. In the dialog box, add a URL in the File field or click on Browse (Choose on MacOS) to find the 

multimedia file on your computer, then click Open. 

4. If necessary, check Show Advanced Options then click OK. 

A replacement text must accompany any video or audio clip. To assign a replacement text: 

1. In the Tags panel, in the tags tree, locate the multimedia file. 

2. Right-click on the tag and select Properties. 

3. Under the Tag tab of the Object Properties dialog box, enter a replacement text in the Actual Text 

field. 

4. Click Close. 
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It is also necessary to provide a transcript for any video or audio sequence, and to ensure that the videos 

include closed or open captions. 

The purpose of a transcription is to provide a coherent alternative to multimedia content. Readers must have 

access to all the information conveyed by the video or audio file, including the dialogues between the 

participating protagonists, the location, the main actions and the atmosphere. 

The transcript may be proposed next to the media file, or in an annex, via a hypertext link. If it’s not the case 

yet, a transcript can be created with a text processing software like Microsoft Word or LibreOffice Writer, for 

example. It can be saved as PDF, and its pages added at the end of the document. Then, insert a bookmark 

linking to the transcript, next to the video or audio object (see Bookmarks). 

To merge a transcript with a PDF document: 

1. Close the two documents to be merged. 

2. Open Adobe Acrobat Pro DC and go to the Tools menu. 

3. Select the Combine Files option. 

4. Click on Add Files, then select the PDF document that contains the video and the PDF document 

that contains the transcript. 

5. If necessary, rearrange the files and pages by dragging and dropping, or deleting the pages that are 

not to be included in the new combined file by clicking on the Remove button. 

6. Once the page order is correct, click the Combine button. 

7. Save the new document created by Adobe Acrobat Pro. 

6. Link text 
Hyperlinks allow users to navigate within the document and navigate to external resources. Links in the form 

of a URL will be announced in full by assistive technologies. Explicit texts should be used to make links 

comprehensible in their context, i.e. the sentence, paragraph, or list element, where they are located. 

To turn a text into a link: 

1. Go to Tools> Edit PDF. 

2. Click the Link icon and select Add/Edit Web or Document Link. 

 

 

3. With the pointer, draw a rectangle around the area where you want to create a link. 

4. In the Create Link dialog box, define the appearance of the link. 
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5. In the Link Action area, select the target type and click Next. 

 

 

6. For external links, in the Edit URL dialog box, enter the URL of the target Web page. 

7. Click OK. 

To add a link text: 

1. In the Tags panel, in the tags tree, locate the link. 

2. Right-click on the <Link> tag (or the <Figure> tag in the case of an image-link) and select 

Properties. 

3. Under the Tag tab of the Object Properties dialog box, enter a replacement text in the Actual Text 

field (or Alternate Text for image-links). 
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4. Click Close. 
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7. Structuring the document appropriately 
1. Applicable RGAA criteria 

 

Category criteria 

Tables 

Criterion 5.1 [A] Does each complex data table have a summary? 

Criterion 5.2 [A] For each complex data table with a summary, is this 

summary relevant? 

Criterion 5.3 [A] For each layout table, is the linearized content still 

understandable (except in particular cases)? 

Criterion 5.4 [A] Does each data table have a title? 

Criterion 5.5 [A] For each data table with a title, is this title relevant? 

Criterion 5.6 [A] For each data table, are each column header and each row 

header correctly identified? 

Criterion 5.7 [A] For each data table, is each cell associated with its header 

cell using the appropriate technique? 

Criterion 5.8 [A] Each layout table must not use elements intended for data 

tables . Has this rule been followed? 

Mandatory 

elements 

Criterion 8.3 [A] On each Web page, is the default human language 

identifiable? 

Criterion 8.4 [A] For each Web page with a default human language, is the 

language code appropriate? 

Criterion 8.7 [AA] On each Web page, is each change in the human language 

identified via the source code (except in particular cases)? 

Criterion 8.8 [AA] On each Web page, is each change in human language 

relevant? 

Criterion 8.10 [A] On each Web page, are changes in reading direction 

identified? 

Information 

structure 

Criterion 9.1 [A] On each Web page, is information structured by the 

appropriate use of headings? 

Criterion 9.2 [A] On each Web page, is the document outline coherent? 

Criterion 9.3 [A] On each Web page, is each list structured  appropriately? 

Criterion 9.4 [AAA] On each Web page, does the first occurrence of each 

abbreviation help to know its meaning? 

Criterion 9.5 [AAA] On each Web page, is the meaning of each abbreviation 

relevant? 

Criterion 9.6 [A] On each Web page, is each quotation identified properly? 

Navigation Criterion 12.13 [A] On each Web page, is tabbing order consistent? 

Consultation 
Criterion 13.9 [AAA] On each Web page, are unusual expressions, idioms or 

jargon made explicit? 
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Criterion 13.10 [AAA] On each Web page, for each expression used in an 

unusual or restricted way, each idiom or jargon with a definition, is this 

definition relevant? 

Criterion 13.13 [AAA] On each Web page, for each word whose meaning 

cannot be understood without knowing the pronunciation, is this 

pronunciation specified? 

Criterion 13.14 [AAA] On each Web page, does each text that requires a 

reading ability more advanced than the lower secondary education level have 

an alternative version? 

2. Introduction 
The notion of structure is central to any document. In a PDF document, this structure must be represented via 

the tags that convey to the reader a primary hierarchy of the content. 

Provided they are correctly tagged, and in a logical order, headings, paragraphs, lists, tables, and other 

structuring elements allow readers to navigate inside the document and find the information they need. 

3. Document title 
The “heading” tag (<H>) identifies the document title (generally present on the first page of the document). 

This tag must appear only once in a given PDF document. 

4. Table of contents 
Tags for tables of contents are nested tags: each chapter or subchapter heading is contained in a <TOCI> tag. 

All <TOCI> tags are grouped in a single <TOC> tag. 

When the table of contents has been created correctly in the source document, hypertext links that allow 

readers to access the contents of the table are preserved when exporting the PDF file. 
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If the table is not tagged, after creating the <TOC> and <TOCI> tags and assigning the contents of the table 

to these tags, iACR 7.5 At is necessary to create hyperlinks to make the table interactive (see Links). 

5. Headings 
To help readers navigate through the document, the headings must be correctly tagged with the appropriate 

level (<H1> to <H6>). 

 

If the PDF document is already tagged, the Acrobat Touch Up Reading Order tool allows you to assign 

heading tags to headings (see The Touch Up Reading Order tool). 
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If an image (<Figure>) is used as a heading, the tag itself must be embedded in a heading tag with 

appropriate alternate text (see Giving an alternative to non-textual elements). 

6. Paragraphs 
Any text that can not be identified by a particular tag must be marked as "Paragraph" (<P>). 

Documents formatted using layout tables require a re-tagging work, because a tabular structure can interfere 

with reading. Table cells must be replaced by paragraphs. 

When auto-tagging from authoring software (Word, Writer, etc.) it is possible that repeating empty <p> tags 

are generated, if the author used a carriage return to create blank spaces. These tags are to be deleted because 

a succession of empty paragraphs can clutter the reading of the document for users of screen readers or text-

to-speech devices. 
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7. Lists 
Lists tagged as paragraphs will not be rendered properly because they will be interpreted as a sequence of 

separate paragraphs. It is therefore imperative to assign appropriate markup to the lists. 

List tags are nested tags. The list elements (<LI>) are grouped together in a single <L>. 

 

For bulleted lists, the bullet itself must be tagged as an artifact (Background). For numbered lists, the number 

must be kept in the <LI> tags. 

List item body (<LBody>) and Label (<Lbl>) tags can exist in PDF documents exported from authoring 

software. They do not interfere with reading, but they do not need to be added manually. 

8. Columns 
To make columns distinct from each other, and easy navigable, the content of each column must be tagged 

separately. 

9. Footnotes 
The <Note> tag marks footnotes. 

Note calls must be marked with a <Span>, with a replacement text indicating that it is a note (for example, 

"See note 19"). 

The position of the <Note> tag can be changed from the logical reading order of the page, so that it is located 

just after the paragraph or the note call. 

10. Quotes 
The <Quote> tag allows you to specify quotes within a paragraph. 

Blocks containing quotes must be identified by the <Blockquote> tag. 

11. Words or groups of words in a foreign language 
Words in a foreign language must be correctly marked so that the text-to-speech devices pronounce them 

correctly. 

To report a language change that applies to the entire content of a tag: 

1. In the Tags navigation panel select the tag that contains text in another language. 

2. Go to Options> Properties. 
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3. Under the Tag tab of the Object Properties dialog box, in the Language box, select a language 

from the drop-down menu. 

 

4. Click Close. 

The contents of all child tags in this tag will be assigned the selected language. 

When it comes to words, or groups of words, that do not correspond to the entire content of the tag, you must 

isolate them with the <Span> tag in order to be able to assign them a language: 

1. In the Tags navigation pane select the tag that contains the text with a word or a group of words in 

another language. 

2. Go to Options> New Tag. 

3. From the Type drop-down list select Span and click OK. 

4. In the Tags navigation panel select the new <Span> tag. 

5. In the View pane, activate the Selection tool on the toolbar, and select the word or group of words in 

another language. 

6. In the Tags navigation pane, open the Options menu and select Create Tag from Selection. 

7. Select the new tag and set the language by following the steps outlined above. 

8. Check that the tag order is correct. 

12. Abbreviations and acronyms 
If the meaning of abbreviations or acronyms is not explained in the text, it shall be indicated by a 

replacement text. 
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In the case of words, or groups of words, that do not correspond to the entire contents of the bounding tag, 

they must be isolated with the <Span> tag in order to be able to attribute meaning to it: 

1. In the Tags navigation panel select the tag that contains the abbreviation or acronym. 

2. If the content of the tag is not limited to the abbreviation or acronym, go to Options> New Tag, and 

from the Type drop-down list select Span and click OK. In the Tags navigation panel select the new 

<Span> tag. In the View panel, activate the Selection tool in the toolbar and select the abbreviation 

or acronym. In the Tags navigation pane, open the Options menu and select Create Tag from 

Selection. 

3. Select the tag that contains the abbreviation or acronym. 

4. In the Tags panel, go to Options> Properties. 

5. In the Object Properties dialog box, under the Tag tab, in the Actual Text box, enter the meaning of 

the abbreviation or acronym. 

 

 

6. Close the dialog box. 

13. Tables 
Tables constitute a complex environment for users of assistive technologies because the organization of 

information and the relationships between them can't be perceived and scanned quickly. 

Tables used for layout purposes only must be removed because a tabular structure can interfere with reading. 

Table cells must be replaced by paragraphs (<P>), see Main tags used. 

For data tables, it is necessary to ensure that each data cell in the table can be correctly linked to the header 

cell(s) that make it meaningful. 

To achieve the best possible results when tagging a table, when you create the source document in authoring 

software like Microsoft Word or LibreOffice Writer, you must use the table creation features. 
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1. Analyzing the existing markup of a table 

The <Table> tag must encompass <TD> (Table Data) or <TH> (Table Header) cells grouped by row in 

<TR> (Table Row) tags. 

 

The Tags panel lets you expand the root of the tags to see if the cells in the table are properly defined, before 

making changes to table elements. 

2. Modification of table markup, and non-supported tags 

8. Simple tables 

If the <Table> tag is missing, or if it is not structured as it should be, the Touch Up Reading Order tool can 

be used to define an appropriate structure for simple tables: 

1. Open the Touch Up Reading Order dialog box. 

2. Select the entire table in the View pane. 

3. Click Table. 
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If this technique does not work (the <TR> and <TD> tags are not created for all content), each tag must be 

created and associated one by one to cells. This procedure of adding tags is a tedious task and can be time-

consuming. 

For the tables that are already tagged, a verification work is necessary to ensure that the contents are 

correctly identified and distributed in a coherent structure. Some cells can be identified as headers (<TH>) 

while they are data cells (<TD>), or vice versa. Some content spread across multiple cells may be 

erroneously merged into a single tag. All these anomalies are to be corrected manually via the Tags 

navigation panel. 
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9. Complex tables 

When the table contains headers that span multiple columns, you must define the ColSpan and RowSpan 

attributes of these rows so that the headers and associated data are accessible and consistent. 

1. In the Tags panel, select a <TD> or <TH> element. 

2. From the Options menu, choose Properties. 

3. In the Properties dialog box, under the Tag tab, click Edit Attribute Objects. 
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4. Select the attribute objects, and then click New Item. 

 

 

5. Expand the new dictionary, select the Layout attribute, and click Change Item. 

6. Change the Layout value to Table. 

7. Select the attribute objects dictionary, and then click New Item. 

8. In the Add Key and Value dialog box, type ColSpan or RowSpan in the Key box. Specify the 

number of merged columns or rows in the Value box. Choose Integer from the Value Type drop-

down menu, and then click OK. 

3. Text alternatives 

A text alternative is necessary to present the function of the data table in its context. Often a detailed 

description of the highlights, or a summary of the data presented in the table is required (see Images and 

charts). 
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8. Creating accessible forms 

1. Applicable RGAA criteria 
 

Category Criteria 

Forms 

Criterion 11.1 [A] Does each form field have a label? 

Criterion 11.2 [A] Is each label associated with a form field relevant? 

Criterion 11.3 [AA] On a given page, or set of pages, all form fields with 

similar functions must have consistent labels. Has this rule been followed? 

Criterion 11.4 [A] In each form, are each label and its related control 

positioned next to each other? 

Criterion 11.5 [A] In each form, is the information of same nature grouped 

together, if necessary? 

Criterion 11.6 [A] In each form, does each form field grouping have a legend? 

Criterion 11.7 [A] In each form, is each legend, related to a form field 

grouping, relevant? 

Criterion 11.8 [A] In each form, is each selection list structured in a relevant 

way? 

Criterion 11.9 [A] In each form, is the text of each button relevant? 

Criterion 11.10 [A] In each form, is the input control used in a relevant way? 

Criterion 11.11 [AA] In each form, is input control accompanied, if necessary, 

by suggestions helping with the correction of input errors? 

Criterion 11.12 [AA] For each form, can financial, legal or personal data be 

changed, updated or retrieved by the user? 

Criterion 11.13 [AAA] For each form, can all data be changed, updated or 

recovered by the user? 

Criterion 11.14 [AAA] For each form, is input assistance available? 

Criterion 11.15 [AAA] For each form, is each input assistance relevant? 

2. Introduction 
A form is an input space, which can have several "fields" where the user can enter text, check boxes, select 

from a list of predefined terms, press buttons, and so on. 

Well-designed forms will be accessible to users of assistive technology, provided they follow a few simple 

rules: 

• The focus path (tab order) must be logical and understandable; 

• Each form field must be identified; 

• Short instructions, or examples of expected input, must be provided; 

• Form fields must be editable. 

All form fields must appear logically in the tags tree, and the user must have access to information through 

tooltips. 
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3. Tagging forms 
Each field of the form must be identified with the <Form> tag and inserted into a paragraph tag (<P>). A 

paragraph can contain multiple <Form> tags. 

If the PDF form is already tagged, the Touch Up Reading Order tool allows you to tag the fields 

appropriately (see The Touch Up Reading Order tool). 

 

Forms formatted using presentation tables must be reworked and tagged again, because a tabular structure 

can interfere with reading. Table cells must be replaced with paragraphs (see Main tags used). 
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4. Identifying fields 
For screen reader users, only the tooltip - directly connected to the field - will be read when the the 

cursor on the field. For this reason, non-tagged field labels must remain as such, and tagged labels 

must be turned into background content (<Artifact>). The information contained in the label will 

be copied in the tooltip. 

To add a tooltip: 

1. Open the Prepare Form tool (Tools> Prepare Form). 
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2. Double-click the form field to which you want to add instructional text. 

 

 

3. Under the General tab of the Text Field Properties dialog box, in the Tooltip text box, 

enter the field label, followed, if necessary, by instructional text. 

4. Click Close. 

For check boxes, the tooltip must repeat the question, followed by the answer (example: What is 

your nationality? American; What is your nationality? Canadian; etc.). 

5. Proposing instructional or help texts 
For some fields, in addition to the label, you must provide in the tooltip instructional text that 

specify the nature or format of the expected input, in order to avoid any ambiguity. Example: “e-

mail (example: yourname@company.com)”. 

6. Defining and testing the tab order 
Once the form is tagged, you must test the tab order, using the keyboard commands to make sure 

it is fully accessible. The following commands allow you to browse the form using the keyboard: 

• Tab to activate next field; 

• Shift + Tab to activate the previous field; 

• Spacebar to select options; 

• Arrow keys to select options presented as radio buttons or items in a list. 

To fix tabbing order issues that may affect the understanding of the form, see Reading order. 
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9. Reading order 
Assistive technologies scan the document in a linear fashion. In documents with a complex layout, the 

different contents do not necessarily appear on the page in a logical order. A heading, for example, may be in 

the middle of a page, whereas it must be read before the content it is associated with. 

In a first step, it is necessary to analyze the document page by page and to decide which modifications are 

necessary in order for the reading order to be coherent. 

1. Defining the reading order with the Touch Up Reading Order tool 
The Touch Up Reading Order tool is intended to provide a quick and easy way to fix reading order issues. In 

the Touch Up Reading Order dialog box, a Show Order Panel button displays the contents of the 

document as gray blocks numbered according to their position in the reading order. Normally, the reading 

order of these areas can be fixed by dragging the highlighted areas into the Order panel. 

However, according to some experts, using the Touch Up Reading Order tool to redefine a reading order is 

risky, because some markup errors may result. Tags can be moved unwillingly into other tags, for example, 

and the order of visual overlay of the contents can also be changed. The impossibility to define the order for 

some embedded tags, handled by the tool as blocks, may also affect the accessibility of the document. For 

these reasons, it is recommended to use the Tags navigation panel to set the reading order. 

2. Defining the reading order with the Tags navigation pane 
Assistive technologies read tags from top to bottom in the tag tree. 

To change the reading order of the page contents, open the Tags navigation pane and move the tags to their 

correct location (see Moving a tag). 
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10. Creating navigation aids 

1. Applicable RGAA criteria 
 

Category Criteria 

Navigation 
Criterion 12.7 [AA] On each page within a collection of pages, are links 

facilitating navigation available? 

2. Introduction 
A document is not necessarily read in a linear fashion. Provided that the document is well structured and 

enriched with navigation elements, users have the ability to move quickly to content inside and outside the 

document. 

3. Bookmarks 
A bookmark is a link giving access to a location, an object, or a selection of text in the document. Rather 

than scrolling through the document to find the text, the user can access it directly using the Bookmarks 

navigation panel. 

When the source documents contain bookmarks, these bookmarks are often tagged and therefore preserved 

when creating PDF files. 

It is also possible to automatically generate bookmarks from headings, for example, provided that the 

document is correctly tagged upstream. 

Bookmarks can also trigger actions, such as sending a form. 

1. Generating tags automatically, from headings or parts of the document 

1. Open the Bookmarks navigation pane. 
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2. Go to Options > New Bookmark from Structure. 

 

 

3. In the list of tags that appears, select the <H1> to <H6> tags, or the <Part> tags. The name of the 

bookmarks is made up from the content of the tags, or from the name of the tags, if you have named 

them. 

 

1. Creating a new bookmark 

 

1. Click the Bookmarks button on the left to open the Bookmarks navigation panel. 
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2. In the View pane, go to the page to which the bookmark will refer. If the bookmark should point to a 

specific text, drag the mouse to select the text. The selected text becomes the title of the new 

bookmark (it is possible to modify this title). To associate a bookmark with an image, click the 

desired image or draw a rectangle around it. 

3. Click the bookmark located just before where you want to insert the new bookmark (otherwise the 

new bookmark is automatically added to the end of the bookmarks list). 

4. In the Bookmarks navigation pane, click Options > New bookmark (or click the New bookmark 

icon). 

5. In the Bookmarks navigation pane, type or change the name of the new bookmark. 

6. In some cases, when the bookmark name is too long for example, it is truncated. In this case it is 

advisable to edit the bookmark name manually to fix it. 

To delete a bookmark, select the bookmark(s), then go to Options > Delete Bookmark(s) or press the Delete 

key (Caution: this deletes its child bookmarks too). 

3. Modifying the destination of a bookmark 

1. In the Bookmarks panel, select a bookmark. 

2. In the View pane, choose the new location to which the bookmark will refer. 

3. From the Options menu, choose Set Bookmark Destination. 

4. Adding an action to a bookmark 

1. In the Bookmarks panel, select a bookmark. 

2. Go to Options > Properties. 

3. In the Bookmark Properties dialog box, click on Actions. 

4. Choose an action in the Select Action menu, then click Add. 
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4. Links 
Hyperlinks allow users to navigate within the document and to external resources. 

When the links have been correctly designed in the source document, they are usually preserved when 

exporting the PDF file. However, it should be checked that the markup is correct and that they are all active. 

The <Link> tag may appear in a paragraph or list item, for example, but must only contain the clickable 

content of the link. 

Internal links allow to reach a page view only. To link to a specific text or word, it is necessary to insert 

bookmarks (see Bookmarks). 

Notes : 

• Foreign language hyperlinks must be correctly marked so that the text-to-speech devices pronounce 

them correctly (see Words or groups of words in a foreign language). 

• By default, the link text is the text contained in the link. It is sometimes necessary to add a 

replacement text to make the destination of certain links unique and less ambiguous (see Link 

text). 
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1. Turning a text into a link 

Use the Create Link command to turn a text into a link: 

1. Go to Tools > Edit PDF. 

2. Click the Link icon and select Add/Edit Web or Document Link. 

3. With the pointer, draw a rectangle around the area where you want to create a link. 

4. In the Create Link dialog box, define the appearance of the link. 

5. In the Link Action section, select the target type for the link and click Next. 

6. For external links, in the Edit URL dialog box, enter the URL of the target Web page. 

7. Click OK. 

8. Finally, add a replacement text to the new link (see Link text). 

2. Setting links tab order 

1. Open the Pages Thumbnails navigation pane. 

 

 

2. Select all page thumbnails. 

3. Right-click one of the thumbnails and select Page Properties. 

4. On the Tab Order tab of the Page Properties dialog box, check Use Document Structure. 

 



51 

 



52 

11. Setting document properties 

1. Introduction 
Document properties, also known as metadata, are information about a file that describes or identifies it. 

They include information such as title, author's name, subject, and keywords identifying the topics or content 

of the document, the document language, and whether some security parameters have been set or not. 

2. Document language 
For text-to-speech software, the language selected for the document determines how the content is spoken. It 

is therefore imperative to define a language for the whole document, and to ensure that any word or passage 

in another language is correctly identified (see Words or groups of words in a foreign 

language). 

To set the document language: 

1. Go to File> Properties. 

2. Under the Advanced tab, in the Reading Options area, select the main language of the document. 

3. Click OK. 



53 

 

 

3. Filling in the document properties 
When opening a document, some assistive technologies refer to the document properties to output the 

document title and sum up its content. 

1. Click File > Properties 

2. To enable assistive technologies to identify and query the document, complete the following fields 

Title, and Author. The Subject and Keywords fields may also be populated, but are not required 

for assistive technologies. 

3. Click OK. 
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4. Informing the reader that the document is tagged 
In order for users of assistive technologies to know the accessibility status of the document, the Document is 

Tagged PDF option should be enabled: 

1. Open the Tags navigation panel. 

2. Go to the Options menu and select Document is Tagged PDF (a check mark appears beside the 

option to indicate that it is enabled). 

5. Defining the protection parameters 
The text of a PDF document must be accessible to screen readers. By default, documents are not protected 

and are therefore accessible to assistive technologies. If the document must be protected to limit modification 

or printing, it is necessary to ensure that the protection parameters do not interfere with the screen reader's 

ability to access the contents of the document. 

To make the document accessible to assistive technologies while limiting editing or printing: 

1. Go to File > Properties. 
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2. Under the Security tab, in the Protection Method box, select Password Protection. 

 

 

3. In the Password Protection - Settings dialog box, in the Rights area, select the “Restrict editing 

and printing...” and “Enable text access options for screen readers devices for the visually 

impaired”. 
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6. Defining the initial view of the document 
You can set the initial view of the document before it is distributed, so that the Bookmarks navigation panel 

is opened when the user opens the document. 

1. Go to File > Properties. 

2. Under the Initial View tab in the Navigation tab area, select Bookmarks and Page Panel. 

3. In the Page Layout area, select Single Page or Single Page Continuous. 

4. In the Show drop-down list, select Document Title. 

5. Click OK. 
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12. Checking the content reflow 
PDF format is often preferred because it allows to preserve the formatting as the author defined it whatever 

the application or the platform used for its reading. However, in order to improve the readability of the 

document for some readers or on some devices such as mobile phones, Adobe Acrobat gives the possibility 

to temporarily reorganize (“reflow”) the contents of the document on a column occupying the full width of 

the display panel. 

A vertical text is reflowed horizontally, giving the possibility to magnify it without having to use the 

horizontal scroll bar. Some complex content (forms, for example) and page artifacts are not reflowed. 

Markup ensures that the contents of the document are correctly reflowed and follow a logical order. When a 

tag is created and associated with content in the Tags navigation pane, a container is created in the Content 

navigation pane. 

To quickly check the reading order of a document, display it in Reflow mode. 

Click View > Zoom > Reflow. 

 

To return to normal view, in Reflow mode, click View > Zoom> Actual Size. 

7. Fixing reflow errors with the Content panel 
The Content panel displays a view of all of the tagged and non-tagged content objects composing a PDF 

document, listed in the order they appear on the page (see The Content panel). 

This panel can list 3 types of content: 
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1. Texts. 

2. Images. 

3. Vector content (usually a vector element is composed of several path-type contents). 

If objects that do not convey information in the context of the document are not already tagged as artifacts, 

this step can be performed via the Content panel: 

1. Return to normal view. 

2. In the Content panel, select the object to be transformed into an artifact. 

3. Right-click and select Create Artifact. 

4. A dialog box lets you choose an artifact type and an anchor position. Leave the option checked by 

default. 

 

To avoid visual overlay issues that may result from content tagging with the Touch Up Reading Order tool, it 

is recommended that the artifacts be positioned - always in the same relative order - at the beginning of the 

tree. Conversely, the tagged contents must be located at the end of the tree. 

To change the position of the contents during reflow: 

1. Choose View > Show / Hide> Navigation Pane> Content. 

2. Expand the document name to display pages and objects. 

3. Move a container or object after selecting it by dragging it to the desired location (or choosing the 

Cut and Paste commands from the Options menu). 
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13. Checking the accessibility of the PDF document ad fixing tagging errors 
Adobe Acrobat Pro DC includes an accessibility checker. Although it allows the identification of certain 

content that can cause reading issues for users of assistive technologies, it only performs automatic controls 

and does not detect a number of barriers to access. 

Before starting the checker, it is possible to select the accessibility issues that will be checked, from a pre-

established list of criteria divided into 4 categories: Document; Page content; Forms, tables and lists; 

Alternate texts and Headings. 

To start the accessibility checker: 

1. Go to Tools > Accessibility. 

2. On the secondary toolbar, on the right side of the screen, click Full Check. 

3. In the Report Options section, specify whether you want to Create an accessibility report (as an 

HTML file) and/or Attached the report to the document. 

4. Select the page(s) you want to check (if the document is a large one, page-by-page checking is 

recommended). 
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5. Choose the check options (by default all options are ticked - it is advised to leave them as such). 

 

 

6. Click Start Checking. The results are displayed in the Accessibility Checker panel. If you have 

created a report, the results are also available in the selected folder. 

The report displays one of the following statuses for each rule check: 

• Pass: The item is accessible. 

• Skipped: The rule was not checked because it was not selected in the Accessibility Checker Options 

dialog box. 

• Needs Manual Check: The Full Check feature could not automatically check the item. Check the 

item manually. 

• Failed: The accessibility of the item could not be confirmed. 

To fix a reported error, right-click the item in the Accessibility Checker panel and select one of the 

following options: 
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• Fix: Acrobat automatically corrects the item or prompts you to fix it manually via a dialog box. 

• Skip rule: untick this option in the Accessibility Checker Options dialog box for subsequent checks 

of this document, and sets the item's status to Skipped. 

• Explain: Opens online help with additional information about the detected issue. 

• Check again: Allows you to check again after modifying one or more elements. 

• Show Report: Displays a report with links to the online support documentation. 

• Options: Opens the Accessibility Checker Options dialog box, so that you can choose which checks 

to perform. 

 

1. Manual checks 
Ideally, you should test the behavior of a tagged PDF file with a screen reader. It is also useful to use the 

reading modes offered by Adobe Acrobat Pro to test the rendering of the document. 

In addition to the Reflow view (see Checking the content reflow), Adobe Acrobat Pro includes a 

Read Out Loud feature. Enabling this feature helps to identify issues with the reading order or to test the 

relevance of some alternate texts. 

To enable the Read Out Loud feature: 

1. Go to View > Read Out Loud > Activate Read Out Loud. 

2. Make sure that each item on the page is read out in a logical order. 
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It may also be useful to save the document in accessible text format to check the quality of the text that will 

be rendered to Braille display users. To export a file to text, go to File > Export to > Text (Accessible). 
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14. Sources 
Atalan / Rendre accessibles les documents PDF avec Adobe Acrobat Pro, version 1.1.5 (2011) - PDF, 5,1 

Mb, in French3. 

Acrobat Documentation / Création d’un fichier PDF accessible (in French)4. 

Acrobat Documentation / Ajout de balises à un document PDF existant (in French)5. 

Acrobat Documentation / Edit document structure with the Content and Tags panels (Acrobat Pro)6 

WebAIM / PDF Accessibility7. 

 

                                                 
3http://www.pdf-accessible.com/wp-content/uploads/2015/01/manuel-balisage-acrobat_AcceDe.pdf 
4http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7d10.w.html 
5http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-

7d09.w.html#WS58a04a822e3e50102bd615109794195ff-7d07.w 
6https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html 
7http://webaim.org/techniques/acrobat/ 

http://www.pdf-accessible.com/wp-content/uploads/2015/01/manuel-balisage-acrobat_AcceDe.pdf
http://www.pdf-accessible.com/wp-content/uploads/2015/01/manuel-balisage-acrobat_AcceDe.pdf
http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7d10.w.html
http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7d10.w.html
http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7d10.w.html
http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7d09.w.html#WS58a04a822e3e50102bd615109794195ff-7d07.w
https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html
http://webaim.org/techniques/acrobat/
http://www.pdf-accessible.com/wp-content/uploads/2015/01/manuel-balisage-acrobat_AcceDe.pdf
http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7d10.w.html
http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7d09.w.html#WS58a04a822e3e50102bd615109794195ff-7d07.w
http://help.adobe.com/fr_FR/acrobat/using/WS58a04a822e3e50102bd615109794195ff-7d09.w.html#WS58a04a822e3e50102bd615109794195ff-7d07.w
https://helpx.adobe.com/acrobat/using/editing-document-structure-content-tags.html
http://webaim.org/techniques/acrobat/
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15. Main tags used 
 

Tag name Type of content 

<Document> Document element. The root element of a document’s tag tree. 

<Part> 
Part element. A large division of a document; may group smaller units of content together, 

such as division elements, article elements, or section elements. 

<Div> Division element. A generic block-level element or group of block-level elements. 

<Art> Article element. A self-contained body of text considered to be a single narrative. 

<Sect> 

Section element. A general container element type, comparable to Division (DIV 

Class=“Sect”) in HTML, which is usually a component of a part element or an article 

element. 

<L> 
List element. Any sequence of items of similar meaning or other relevance; immediate 

child elements should be list item elements. 

<LI> 
List item element. Any one member of a list; may have a label element (optional) and a list 

body element (required) as a child. 

<BlockQuote> 
Block quote element. One or more paragraphs of text attributed to someone other than the 

author of the immediate surrounding text. 

<Caption> Caption element. A brief portion of text that describes a table or a figure. 

<Index> 
Index element. A sequence of entries that contain identifying text and reference elements 

that point out the occurrence of the text in the main body of the document. 

<TOC> 
Table of contents element. An element that contains a structured list of items and labels 

identifying those items; has its own discrete hierarchy. 

<TOCI> 
Table of contents item element. An item contained in a list associated with a table of 

contents element. 

<Table> 

Table element. A two-dimensional arrangement of data or text cells that contains table row 

elements as child elements and may have a caption element as its first or last child 

element. 

<TR> 
Table row element. One row of headings or data in a table; may contain table header cell 

elements and table data cell elements. 

<TD> Table data cell element. A table cell that contains non header data. 

<TH> 
Table header cell element. A table cell that contains header text or data describing one or 

more rows or columns of a table. 
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Tag name Type of content 

<Quote> 

Quote entry element. An inline portion of text that is attributed to someone other than the 

author of the text surrounding it; different from a block quote, which is a whole paragraph 

or multiple paragraphs, as opposed to inline text. 

<Code> Code entry element. Computer program text embedded within a document. 

<Figure> Figure entry element. A graphic or graphic representation associated with text. 

<Form> Form entry element. A PDF form annotation that can be or has been filled out. 

<Formula> Formula entry element. A mathematical formula. 

<Link> 
Link entry element. A hyperlink that is embedded within a document. The target can be in 

the same document, in another PDF document, or on a website. 

<Note> 
Note entry element. Explanatory text or documentation, such as a footnote or endnote, that 

is referred to in the main body of text. 
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16. License 
This document is the property of the Secrétariat général à la modernisation de l'action publique (SGMAP). It 

is placed under Open Licence 1.0 or later (PDF, 541 kb)8, equivalent to a Creative Commons BY license. To 

indicate authorship, add a link to the original version of the document available on the DINSIC's GitHub 

account9. 

 

                                                 
8http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf 
9https://github.com/DISIC 

http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf
https://github.com/DISIC
https://github.com/DISIC
http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf
https://github.com/DISIC
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