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1. Introduction 

1. Foreword 
French law n° 2005-102, of 11 February 2005, for equality of rights and opportunities, participation and 

citizenship of people with disabilities, makes accessibility a requirement for all public online communication 

services, for the State, local and regional authorities and the public institutions that depend on them. 

The RGAA (General Accessibility Framework for Administrations) aims to promote accessibility of the 

contents available in digital form. In 2014, the RGAA was redesigned to be up-to-date and more operational. 

The French administrations currently ought to refer to the RGAA 3. 

To meet the needs of diverse groups and contexts, three levels of compliance have been defined: A (lowest), 

AA and AAA. The level legally expected is level double-A (AA). Success criteria associated with the AAA 

level may be taken into account in certain contexts where possible and relevant. 

2. The RGAA and office documents 
The RGAA applies to any document or application available online: websites, Intranet and web applications, 

but also the contents downloadable as separate files. 

In the Consultation category of the RGAA, criterion 13.71 (Level A) states that "each office document that 

can be downloaded [must] have an accessible version if necessary". Compliance with this criterion can be 

achieved in particular by providing an accessible HTML version or by making the document accessible in 

the format proposed for download. 

This companion guide presents the considerations and principles for creating an accessible Writer document 

with LibreOffice Writer 5.2, along with non-normative guidance and procedures for implementing them. 

Each chapter is divided into topics and incorporates a reference to the corresponding RGAA criteria. 

3. Who is this guide for? 
These guides are intended for all professionals in government departments, local authorities, agencies, public 

institutions, public enterprises or anyone wishing to: 

• Produce accessible office documents; 

• Improve the accessibility of existing office documents; 

• Test the level of accessibility of office documents already created. 

4. Technical devices used to access content 
A document is accessible if it can be accessed by any user, regardless of the computer tool being used. More 

and more users are using assistive technologies to overcome barriers to accessing office documents or web 

content. These technical solutions include 

• Software assistive technologies (screen readers, voice recognition / dictation software, etc.); 

• Hardware assistive technologies (adapted mice, trackballs, Braille displays, etc.). 

Content and applications must be compatible with these various assistive technologies, their functionalities 

and uses. 

5. About this translation 
The original document, in French, refers to the LibreOffice suite in its 4.3 version. At the time of translation, 

the current, more easily available version is 5.2 and above. This translation takes this fact into account and is 

based on the features of version 5.2 where applicable. Consequently, there may be slight variations from the 

original material. 

                                                 
1 URL: https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7 

https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7
https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7
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6. Conventions 
This document indicates keyboard shortcuts for commands used in the LibreOffice suite. In the Windows 

operating systems family, the CTRL (Control) key is used as a modifier for many shortcuts. In the MacOS 

system, the equivalent modifier key is CMD (Command, represented by the ⌘ symbol). In the rest of this 

document, for clarity, only the Windows shortcut (with CTRL) will be mentioned. Mac users are invited to 

replace it with CMD. 

Texts in bold generally refer to commands and menus available in the user interface. Indications like “File > 

Save” must be understood as “Open the File menu, and then select the Save item in this menu”. 

Mentions like “Right-click on...” actually refer to opening a contextual menu, associated with an item. On 

most systems, this is usually done by clicking on the item with the right button of a mouse or a trackpad. 

Another method, on Windows, consists in pressing the “Menu” key on the keyboard. On MacOS based 

systems, pressing the CTRL key and the left button simultaneously has the same effect. Unfortunately, there 

is no easy way to activate a contextual menu through a keyboard on a Mac. 
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2. How to structure a document 

1. Applicable RGAA Criteria 
 

Category Criteria 

Information 

Structure 

Criterion 9.1 [A] On each Web page, is information structured by the 

appropriate use of headings? 

Criterion 9.2 [A] On each Web page, is the document outline coherent? 

Criterion 9.3 [A] On each Web page, is each list structured  appropriately? 

Criterion 9.5 [AAA] On each Web page, is the meaning of each abbreviation 

relevant? 

Criterion 9.6 [A] On each Web page, is each quotation identified properly? 

Navigation Criterion 12.13 [A] On each Web page, is tabbing order consistent? 

2. Introduction 
The notion of structure is central to any document. In addition to facilitating reading, formatting (font, size, 

spacing, etc.) and the position of the elements convey to the reader a first glimpse of the hierarchy of the 

content. 

When applied correctly, the use of styles - a set of formatting features - allows a structure to be quickly and 

easily attributed to the document, while ensuring that the structure is accessible and navigable by users of 

assistive technologies. 

When composing the document, the use of layout features in LibreOffice Writer (layout of text in columns, 

anchoring of inserted objects) makes it possible to ensure that all the elements of the document follow a 

logical order, and that they are easily reachable via the keyboard and easily read with assistive technologies. 

3. Navigator 
LibreOffice includes a powerful tool to access directly to the various elements of a document: the Navigator. 

This feature is also useful to control the document structure and ensure that the elements it is composed of 

are correctly identified. 



7 

There are 3 ways to open the Navigator: 

1. View > Navigator. 

2. Click on the icon in the sidebar. 

3. Press the F5 key. 

To display the elements of a category, click on the triangular arrow next to the category name. To access 

quickly to an element in the document, double-click on it in the Navigator. 
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4. Headings 
The primary elements that allow to  structure text are headings and sub-headings. 

To begin with, any text in a new Writer document is assigned a default style, corresponding to “Text Body”. 

Then different sets of quick styles are proposed. To activate the quick styles: 

1. Select the text you want to turn into a heading. 

2. Go to Styles > Styles and Formatting 

3. In the Styles and Formatting dialog box, click on the triangular arrow next to Heading. 

4. Double-click on the heading level you want to apply. 
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It is also possible to create your own headings styles and save them: 

1. Apply the desired style of heading (see above for instructions) 

2. Use the characters formatting tools to make the desired changes. 

3. Select the formatted heading you want to save. 

4. Go to Styles > New Style... 

5. In the Create Styles dialog box, type in a name for your style, and click OK. 
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Please note: 

• The application of styles for headings must imperatively respect the contents hierarchy, without 

skipping levels; 

• Heading styles should never be used for formatting purposes only; 

• Generally, headings should not exceed one line; 

• To facilitate browsing in longer documents, there should be at least one heading every two pages; 

Verification: 

Empty headings can be identified using the Navigator. 
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To delete one, click on the empty heading, and edit the document to remove it. 

5. Paragraphs 
Any paragraph text must be identified as such with the "Text Body" style (default style). 

Repeated line breaks inserted to space the text of a document are to be avoided, because a succession of 

empty paragraphs can be perceived by the user of a screen reader or a speech synthesizer as indicating the 

end of the document. Blank spaces can be made by applying styles with larger or smaller spacings as 

required. 
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To specify the desired spacing values for one or more paragraphs: 

1. Move the mouse to the paragraph and click in it, or select the paragraphs you want to style. 

2. Go to Format > Paragraph… 

3. In the Spacing area, under the Indents & Spacing tab, select the desired spacing values to be 

applied before and after the paragraph. 

 

Similarly, when you want to continue writing on a new page, you must insert a page break rather than a 

succession of line breaks. To insert a page break, you can use CTRL + Enter, or go through the menus: 

1. Click in the location where you want to start a new page. 

2. Under the Insert tab, click Page Break. 

Empty paragraphs can be deleted manually. To view the paragraph marks, select Nonprinting characters (a 

button that looks like a reverse P with a double leg) or press F10. 
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6. Lists 
Lists created only by inserting dashes in the form of "-" signs or other special characters will not be rendered 

correctly by certain assistive technologies, that will interpret them as a series of separate paragraphs. It is 

then imperative to create lists identified as such by LibreOffice Writer. 

LibreOffice Writer allows you to create bulleted lists or automatically numbered lists, if this option has been 

activated. 

1. Go to Tools > AutoCorrect > AutoCorrect Options... 

2. Select the Options tab 

3. Check the Bulleted and numbered lists box. 

 

4. Go to Tools > AutoCorrect  and check that the While Typing option is checked. 

To create a list automatically: 

1. Start a paragraph by an asterisk (*) or the number 1. 

2. Insert a line break and the next paragraph will be automatically transformed into a list item. 

To create a list manually: 

1. Select the text you want to transform into a list. 
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2. Click on the Bullets On/Off or the Numbering On/Off button, or go to Format > Bullets & 

Numbering...  

 

3. Under the Options tab of the Bullets & Numbering dialog box, select the type of numbering you 

wish to apply. 

4. Click OK 

 

To create a sublist, it is not appropriate to create a simple visual indentation. Instead, you need to indicate 

that the sublist is one of the items of the parent list: 

1. Select the items to be included in a sublist. 

2. Click on Increase Indent. 

 

Please note: 

• The automatic numbering option is only applicable to paragraphs formatted with the “Standard”, 

“Text Body” or “Text Body Indent”. To number headings automatically, go to Tools > Outline 

Numbering… 

• To stop the automatic insertion of a bullet or number, at the end of a list, press the Enter key twice. 

• To remove bullets or numbering on paragraphs, select the paragraphs, and click, on the Bullets 

On/Off or Numbering On/Off button, that should appear as pressed. 

7. Footnotes 
Footnotes and endnotes contain additional information. They are made up of two related parts, namely the 

footnote (or endnote) indicator and the text of the corresponding note. 

The user can navigate between text and notes, provided they have been inserted correctly: 

1. In the document, place the edition cursor where you want to insert a footnote. 

2. Go to Insert > Footnote and Endnote. Click Footnote to use the default settings, and type your 

footnote directly. Click Footnote or Endnote… to use your own settings. 

3. If you choose to define your own settings, the Insert Footnote / Endnote dialog box is displayed. To 

use a special character, check the Character option and click Choose… to pick up a special character. 

4. Select the Type of note, blick OK and type your note. 
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8. Page numbers 
Page numbers provide  important landmarks for any user, including users of assistive technology. 

You can insert page numbers at the top (header) or at the bottom (footer) of the page. In the following 

procedure we will insert page numbers in the footer: 

1. Go to Insert > Header and Footer > Footer  and select the style to apply (if you haven’t defined 

styles yet, the only available style is Default). 

2. Place the edition cursor in the footer and click Insert > Page Number. 

9. Columns 
Mock-columns, created with the tab key or using a data table, can cause difficulties for assistive technology 

users. To organize a part of the document into separate and easily navigable columns: 

1. Select the text you want to convert to columns. 

2. Go to Format > Columns… 
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3. In the dialog box, select the settings, the width and spacing, and the type of separation line.  

 

 

10. Floating objects 
When images or objects are inserted into a LibreOffice Writer document, they are positioned relatively to the 

page by default, and remain in the same position when the user browses the page. This behavior makes these 

"floating objects" difficult to select through a keyboard. It is important to ensure that the objects inserted in a 

document remain associated with the text to which they refer, by defining an anchor point “As character”: 

1. Right-click on the object (a picture in this example) and select Anchor > As Character. 

2. Move the object at the desired insertion point. 

Likewise, the insertion of multiple graphic elements (eg arrows and shapes) directly into the document 

without proper anchoring can make these elements difficult to identify and understand. The editing tools 

dedicated to the layout, can be used to create standalone and complete charts (see  26 Giving an 

alternative to non-textual elements). 

11. Reading order 
Assistive technologies scan the document in a linear fashion. Some precautions need to be taken so that the 

reading order is consistent: 

• Do not use data tables for layout of contents (text or images) in the document; 

• Do not use tab keys to create columns; 

• Do not use editable text areas to highlight some given content, but use styles instead. 
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12. Text Areas 
Text areas are often problematic because they can be ignored by some screen readers. For this reason, it is 

better to create a box by applying a style. To do this: 

1. Select the text you want to be framed. 

2. Go to Format > Paragraph... 

3. Under the Border tab, of the Paragraph dialog box, set the desired border style. 

4. Under the Area tab, select a background color. 

5. Click OK. 
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3. Using an appropriate presentation 

1. Applicable RGAA Criteria 
 

Category Criteria 

Colors 

Criterion 3.1 [A] On each Web page, information must not  be conveyed 

through color only. Has this rule been followed? 

Criterion 3.2 [A] On each Web page, information   must not be conveyed 

through color only. Has this rule been implemented in a relevant way? 

Criterion 3.3 [AA] On each Web page, is the contrast between the text and 

background colors sufficient (except in particular cases)? 

Criterion 3.4 [AAA] On each Web page, is the contrast between the text and 

background colors enhanced (except in particular cases)? 

Mandatory 

Elements 

Criterion 8.9 [A] On each Web page, tags must not be used only for layout. 

Has this rule been followed? 

Presentation 

of information 

Criterion 10.6 [A] On each Web page, can each link whose nature is not 

obvious be distinguished from the surrounding text? 

Criterion 10.12 [AAA] For each Web page, is line and paragraph spacing 

sufficient? 

Criterion 10.13 [A] For each Web page, are hidden texts correctly rendered 

by assistive technologies? 

Criterion 10.15 [A] On each Web page, information must not be conveyed 

by shape, size or location alone. Has this rule been implemented in a 

relevant way? 

2. Introduction 
The visual complexity of a document (the quantity, density and variety of fonts, colors, texts, etc.) can play a 

decisive role in understanding its content. For users browsing with assistive technologies, a complex 

document often relies on a complex structure and may require more time to apprehend. If the understanding 

of certain content is conveyed only through color, shape, size or position, these readers may miss some 

information. 

When composing the document, the use of standard styles and fonts improves its readability. 

3. Templates and styles 
A template serves as the basis for new documents and contains predefined formatting styles. 

In LibreOffice Writer, you can create your own accessible template from blank content, or edit and modify 

pre-existing templates: 

1. Make sure the document meets the structuring, presentation, language,description and navigation 

rules proposed in this guide. 

2. Go to File> Properties… 

3. In the title and/or the comment box, emphasize the accessibility of the template and close the dialog 

box by clicking OK. 

4. Go to File > Templates > Save as Template... 

5. Select the category for your template. 
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6. Type a name for your template in the Enter Template Name box. 

7. Close the dialog box by clicking Save. 

 

Styles can be used to give a hierarchical structure to the document (see 8 Headings), but also to highlight 

certain types of content (quote, caption, etc.). In order to allow readers to understand the meaning of 

formatting, it is appropriate to use styles management features proposed by LibreOffice Writer rather than 

directly using character formatting tools. 

To apply quick styles: 

1. Select the text you want to apply a style to. 

2. Go to Styles > Styles and Formatting... 

3. In the Styles and Formatting dialog box, double-click on the type of style to apply. 

To change the characteristics (colors, font face, size or weight) of an existing style: 

1. Go to Styles > Styles and Formatting… 

2. Select a style you want to modify. 
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3. Right-click on it and select Modifiy... 

4. Select, for instance, the Font Effects tab. 

5. Select the font effects settings to apply. 

6. Confirm by clicking OK. 

 

1. Colors 
If information is conveyed only through color, screen reader users (blind or visually impaired users, in 

general) and some color blind people will not be able to access it. Any information conveyed through color 

must therefore also be available via another means (for example, an appropriate style). 

For information provided through color in text, the solution is to add an explanatory text. For example, in 

this procedure: 

1. Do this. 

2. Do that. 

3. Do something else. 

4. Finish by... 

Note: the steps in blue are optional. 
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The only way to fix it is to change the note: 

1. Do this 

2. Do that 

3. Do something else 

4. Finish by... 

Note: the steps in blue (2 and 3) are optional. 

The contrast between the background and text colors must also be sufficient to make the reading of the 

document comfortable. The RGAA states that the contrast ratio between a non-bold text and its background 

should be 4.5:1 up to 150% of the default font size, and 3:1 beyond. For bold text, a 4.5:1 contrast ratio is 

required up to 120% of the default font size, and 3:1 beyond. This applies to text, graphics and images. 

A contrast checker is used to determine if colors have sufficient contrasts. The Colour Contrast Analyser2, 

provided by the Paciello Group, can be downloaded free of charge. 

Among others, you may also use this online checker proposed by Tanaguru3. 

2. Fonts 
For the reasons given above, it is compulsory to use the styling features rather than the character formatting 

tools, to format any element with a semantic value (headings, list elements, notes, etc.). 

Whenever possible, some formatting standards should be prioritized to facilitate reading, and make the 

documents legible in the main text editors. 

• Standard fonts created for ease of reading: Arial, Calibri, Cambria, Constantia, Garamond, Georgia, 

Helvetica, Times New Roman, Trebuchet MS, and Verdana; 

• Font sizes between 12 and 18 points for the body text; 

• Normal or expanded character spacing, rather than condensed. 

Avoid: 

• Long chunks of text in uppercase, italic or underlined fonts 

• Animated or scrolling text. 

                                                 
2https://www.paciellogroup.com/resources/contrastanalyser/ 

3http://contrast-finder.tanaguru.com/?lang=en 

https://www.paciellogroup.com/resources/contrastanalyser/
http://contrast-finder.tanaguru.com/?lang=en
https://www.paciellogroup.com/resources/contrastanalyser/
http://contrast-finder.tanaguru.com/?lang=en
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4. Language 

1. Applicable RGAA Criteria 
 

Category criteria 

Mandatory 

elements 

Criterion 8.3 [A] On each Web page, is the default human language 

identifiable? 

Criterion 8.4 [A] For each Web page with a default human language, is the 

language code appropriate? 

Criterion 8.7 [AA] On each Web page, is each change in the human language 

identified via the source code (except in particular cases)? 

Criterion 8.8 [AA] On each Web page, is each change in human language 

relevant? 

Criterion 8.10 [A] On each Web page, are changes in reading direction 

identified? 

Information 

Structure 

Criterion 9.4 [AAA] On each Web page, does the first occurence of each 

abbreviation help to know its meaning? 

Consultation 

Criterion 13.9 [AAA] On each Web page, are unusual expressions, idioms or 

jargon made explicit? 

Criterion 13.10 [AAA] On each Web page, for each expression used in an 

unusual or restricted way, each idiom or jargon with a definition, is this 

definition relevant? 

Criterion 13.13 [AAA] On each Web page, for each word whose meaning 

cannot be understood without knowing the pronunciation, is this 

pronunciation specified? 

Criterion 13.14 [AAA] On each Web page, does each text that requires a 

reading ability more advanced than the lower secondary education level have 

an alternative version? 

2. Introduction 
When the contents of a document are well identified, organized according to a coherent logic, and well-

spaced, they are easier to consult. Similarly, documents with clear headings, short paragraphs and concise, 

simple, jargon-free sentences will be accessible to as many people as possible. 

When it is necessary to use technical terms, words in a foreign language or abbreviations, it is important to 

give the reader the information necessary for their proper understanding. 

3. Language of the document 
The language selected for the document determines the dictionary used for spell checking, synonyms and 

hyphenation, as well as a number of formatting rules. For text-to-speech software, it also determines how 

content is spoken. It is therefore imperative to define a language for any document, and to ensure that any 

word or passage in another language is correctly identified (see  Words or passages in a foreign 

language). 

To set the language for the document: 

1. Go to: 

1.  File > Options… in Windows 
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2. LibreOffice > Preferences in MacOS 

2. Open the Language Settings menu and select Languages. 

3. In the Default Languages Settings section, choose the chosen language. To apply this setting for 

the current document only, check the corresponding check box. 

4. Close the dialog box by clicking OK. 

 

4. Abbreviations, acronyms and abbreviations 
In LibreOffice Writer 5.2, there is no mechanism for identifying acronyms, or abbreviations. 

To facilitate understanding, the meaning of abbreviations and acronyms shall be indicated in clear text in 

their first occurrences, followed by the abbreviation or acronym between parentheses. For example: National 

Aeronautics and Space Administration (NASA). 

You can also link an acronym or an abbreviation to a glossary via a bookmark or a hyperlink (see 39 

Bookmarks), or propose a definition in a tooltip: 

1. Select the text to be “defined” 

2. Go to Insert > Fields > More Fields… 

3. Under the Cross-References tab, in the Type section, select Set Reference 

4. In the Name field, type in a name for your reference, then click Insert. 
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5. Unusual, idiomatic or specialized expressions 
When it is necessary to use unusual, idiomatic or specialized expressions, an accessible definition must be 

provided. These definitions can be proposed in the footnotes or endnotes (see 14 Footnotes), or grouped 

in a glossary and connected by bookmarks (see 39 Bookmarks). 

6. Words or passages in a foreign language 
Words in a foreign language must be correctly marked so that the speech synthesizers pronounce them 

correctly. To indicate a change of language: 

1. Select the text passage in another language. 

2. Go to Format > Character 

3. In the Character dialog box, open the 

4. Select the appropriate language. 

5. Click OK. 
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No visual changes will occur; only assistive technologies will have access to this information. 
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5. Giving an alternative to non-textual elements 

1. Applicable RGAA criteria 
 

Category criteria 

Images 

Criterion 1.1 [A] Does each image have a text alternative? 

Criterion 1.2 [A] For each decorative image with a text alternative, is this 

alternative empty? 

Criterion 1.3 [A] For each image conveying information with a text 

alternative, is this alternative relevant (except in particular cases)? 

Criterion 1.6 [A] Does each image conveying information have a detailed 

description if necessary? 

Criterion 1.7 [A] For each image conveying information with a detailed 

description, is this description relevant? 

Criterion 1.8 [AA] When an alternate mechanism is missing, each image of 

text conveying information must be replaced with styled text, if possible. 

Has this rule been followed (except in particular cases)? 

Criterion 1.9 [AAA] Each image of text conveying information must be 

replaced with styled text. Has this rule been followed (except in particular 

cases)? 

Criterion 1.10 [A] Is each image caption correctly associated with the 

corresponding image, if necessary? 

Colors 

Criterion 3.1 [A] On each Web page, information must not  be conveyed 

through color only. Has this rule been followed? 

Criterion 3.2 [A] On each Web page, information   must not be conveyed 

through color only. Has this rule been implemented in a relevant way? 

Criterion 3.3 [AA] On each Web page, is the contrast between the text and 

background colors sufficient (except in particular cases)? 

Criterion 3.4 [AAA] On each Web page, is the contrast between the text and 

background colors enhanced (except in particular cases)? 

Consultation 

Criterion 13.11 [A] On each Web page, does each cryptic content (ASCII art, 

emoticon, leetspeak) have an alternative? 

Criterion 13.12 [A] On each Web page, for each cryptic content (ASCII art, 

emoticon, leetspeak) with an alternative, is this alternative relevant? 

Criterion 13.15 [A] On each Web page, are sudden changes in luminosity or 

flashing effects used appropriately? 

Criterion 13.16 [AAA] On each Web page, do the sudden changes in 

luminosity or flashing effects have a frequency lower than or equal to 3 per 

second? 

Criterion 13.17 [A] On each Web page, can each moving or blinking content 

be controlled by the user? 
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Multimedia 

Criterion 4.1 [A] Does each prerecorded time-based media have a text 

transcript or an audio description if necessary (except in particular cases)? 

Criterion 4.2 [A] For each prerecorded time-based media with a text 

transcript or a synchronized audio description, are these relevant (except in 

particular cases)? 

Criterion 4.3 [A] Does each prerecorded synchronized time-based media 

have synchronized captions if necessary (except in particular cases)? 

Criterion 4.4 [A] For each prerecorded synchronized time-based media with 

synchronized captions, are these captions relevant? 

Criterion 4.5 [AA] Does each live time-based media have synchronized 

captions or a text transcript if necessary (except in particular cases)? 

Criterion 4.6 [AA] Are each synchronized captions or text transcript, 

provided for live time-based media, relevant? 

Criterion 4.7 [AA] Does each prerecorded time-based media have a 

synchronized audio description if necessary (except in particular cases)? 

Criterion 4.8 [AA] For each prerecorded time-based media with a 

synchronized audio description, is this audio description relevant? 

Criterion 4.9 [AAA] Does each prerecorded time-based media have a sign 

language interpretation (except in particular cases) if necessary? 

Criterion 4.10 [AAA] For each prerecorded time-based media with a sign 

language interpretation, is this interpretation relevant? 

Criterion 4.11 [AAA] Does each prerecorded time-based media have a 

synchronized extended audio description if necessary (except in particular 

cases)? 

Criterion 4.12 [AAA] For each prerecorded time-based media with a 

synchronized extended audio description, is this audio description relevant? 

Criterion 4.13 [AAA] Does each synchronized or video-only time-based 

media have a text transcript (except in particular cases)? 

Criterion 4.14 [AAA] For each synchronized or video-only time-based 

media with a text transcript, is this text transcript relevant? 

Criterion 4.15 [A] Can each time-based media be clearly identified (except 

in particular cases)? 

Criterion 4.16 [A] Does each non time-based media have, if necessary, an 

alternative (except in particular cases)? 

2. Introduction 
Non-textual elements are becoming increasingly important in office documents. Photos, maps, graphics and 

mathematical formulas enrich documents and convey information to readers. 

For non-textual elements that convey information not presented as text in their proximity, this information 

must be described in a replacement text. Without proper description, these elements can't be perceived by 

assistive technologies, that will signal the presence of a graphic element without any other information. 

It is possible to create a replacement text that will be returned to the reader by assistive technologies. The 

tools vary according to the nature of the non-textual content. 
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3. Images 
You should ask yourself 3 questions before choosing the text that will be rendered in place of the image: 

• Is the image purely decorative, not conveying any information and having no function? 

• Does the item convey information? 

• Does the image have a function (for example, a picture serving as a link)? 

If the image is purely decorative, it should not be assigned alternative text. 

If the image conveys information, it must be associated with a replacement text. This alternative, which also 

serves as a title, must succinctly describe the information conveyed by the image and its meaning in the 

context. 

For an image that serves as a hyperlink, the alternate text must be able to understand the function and the 

destination of the link. The conditions for returning this replacement text require that it be as short as 

possible (a maximum length of 80 characters is strongly recommended). If the information requires a longer 

alternative, a detailed description must be provided. 

A replacement text should not: 

• Duplicate information in the caption; 

• Include copyright information (for example, for a photo, the name of the copyright holder and the 

date of the picture) 

• Start with "picture of..." or "photo of...". 

To associate an alternative text to an image that conveys information or serves as a hyperlink: 

1. Right-click on the image and select Properties... 

2. In the Image dialog box, under the Options tab, in the Alternative (Text only) input box, type the 

alternative text. 

3. Click OK. 
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Note that if an image is replaced (right-click on the image and select Replace…), its alternative text will be 

preserved. If necessary, update this alternative text accordingly. 

A detailed description is sometimes necessary when the information conveyed by the image is more 

complex. This requires an interpretation of the image. 

There is no embedded mechanism in LibreOffice Writer 5.2 to associate a detailed description with an image. 

However, you can add a link on the image itself, in the caption, or next to the image, pointing to a detailed 

description in an annex of your document. Create this annex and the detailed description, and see the Links 

section for detailed procedure to link to it. 

The textual alternative can be completed with a caption visible to all. To insert a caption: 

1. Right click on the image, then select Insert Caption... 

2. In the Insert Caption dialog box, fill in the Caption field, select the desired settings, then click OK. 

You can edit the text of a caption directly in the document. 
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4. Images of text 
Images of text are images that contain text that is necessary to understand the content of the document. It is 

not recommended to use images of texts when it is possible to reproduce the same effects by defining styles 

for "actual" text (see Templates and styles). 

If the text is part of a logo or an element associated with the graphic identity of an organization or a 

company, it is advisable to propose a textual alternative to the image, while following the recommendations 

above. 

5. Charts 
The data shown in charts can range from very simple to very complex. Initially, a chart accessible to color-

blind and partially sighted readers should be created. This involves to: 

• Not use color alone to convey information (use of textures or shapes to differentiate the components 

of the graph for example); 

• Emphasize the use of dashed line styles to improve readability; 

• If necessary, replace predefined colors to meet the contrast requirements (see Colors). 

To insert a chart and define its visual aspect: 

1. Go to Insert > Chart… 
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2. Right-click in the chart area (outside of any of its inner objects), and click Chart Type… 

3. Select the desired type and click OK. 

4. Right-click on the chart, and select Data Table… 

5. Update the chart with your data and click OK. 

6. Righ-click on one of the shapes to change its colors, and select Format Data Series… 

7. In the Data Series dialog box, under the Area tab, in the Fill selection list, select Hatching. 

8. Choose a texture, then check the Background Color box and select a color with a satisfying 

contrast. 

 

Once the chart is created, it should be assigned a title, and its elements should be appropriately labeled. 

1. Select the chart. 

2. Go to Insert > Titles 
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3. Complete the relevant fields and click OK. 

 

4. Go to Insert > Data Labels… 

5. Define settings for the data labels and click OK. 

The title and labels of the axes provide necessary elements for the interpretation of the data presented, but 

will not suffice to transmit the specifics of the graphic necessary for its comprehension to someone who fails 

to see it. 

For simple charts, a simple replacement text may suffice. For more complex or detailed charts, it is necessary 

to provided a detailed description. In both cases, it is necessary to avoid listing the raw data as a textual 

alternative, but rather to explain the information that you wish to convey by inserting the chart in the 

document. 

To add a replacement text: 

1. Select the chart. 

2. Right click on the chart, then select Object... 

3. In the Object dialog box, under the Options tab, fill the Alternative (Text only) field. If any, 

mention the existence of a detailed description, and orient the reader to it (indicate its location, or the 

existence of a link to it). 

4. Click OK. 

If necessary, provide a detailed description (see Images for a workaround based on links). 
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If possible, a version of the data presented in the chart should also be provided as a list or table. 

6. Mathematical formulas 
LibreOffice includes a formulas editor that works with all applications in the LibreOffice suite. It allows the 

insertion of mathematical and scientific formulas formatted and readable by assistive technologies. These 

formulas can be converted into accessible formats. 

The formulas are written in a special module (Math) and inserted in the text in the same way as the charts. 

This way, they can be exported in MathML format, which can be rendered by assistive technologies. 

To insert a formula: 

1. Go to the Insert > Object > Formula.... 

2. The Math module opens with an Elements pane with predefined symbols, and an edition window at 

the bottom to manually enter the formula. Right-click at the bottom to open a contextual menu that 

provides access to the Equation Editor commands. 

3. Once the formula is entered, you must click on the page to exit the Math module. 
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6. Creating accessible tables 

1. Applicable RGAA criteria 
 

Category criteria 

Tables 

Criterion 5.1 [A] Does each complex data table have a summary? 

Criterion 5.2 [A] For each complex data table with a summary, is this 

summary relevant? 

Criterion 5.3 [A] For each layout table, is the linearized content still 

understandable (except in particular cases)? 

Criterion 5.4 [A] Does each data table have a title? 

Criterion 5.5 [A] For each data table with a title, is this title relevant? 

Criterion 5.6 [A] For each data table, are each column header and each row 

header correctly identified? 

Criterion 5.7 [A] For each data table, is each cell associated with its header 

cell using the appropriate technique? 

Criterion 5.8 [A] Each layout table must not use elements intended for data 

tables. Has this rule been followed? 

2. Introduction 
Tables constitute a complex environment for users of assistive technologies because the organization of 

information and the relationships between them can't be perceived and scanned quickly. It is necessary to 

ensure that each data cell in the table can be correctly linked to the header cell(s) that make it meaningful. 

3. Layout tables 
The use of tables for layout purposes is generally not a good practice: it is preferable to use the layout 

functions (columns, borders, etc.). To layout a text in columns, for example, it is appropriate to use the 

functionality described here: 15 Columns. 

The use of the tab key and the space bar to simulate tables of data is to be avoided because assistive 

technologies are not able to interpret this type of formatting. 

4. Formatting 
If a data table proves to be the best option to present information, it is necessary to follow some formatting 

rules in order to make the presented data accessible and comprehensible to the greatest number: 

• Create a uniform table facilitating the identification of each cell and its significance in the context. 

• Prefer several simple tables to more complex tables. 

• Avoid nesting tables in one another. 

• If possible avoid merged cells. 

• Eliminate empty cells - if data is missing, replace it with an explicit mention. 

• Generate blank spaces using styles (see Templates and styles) and not by inserting blank 

rows. 

• Avoid inserting images within the table. 

It is then necessary to identify the contents of the table by means of the headers, the caption, and the 

alternative text, and to define these properties to allow a better experience for  screen readers users. 
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1. Row and column headers 
The row and column headers indicate the relationship between the data presented. To specify the presence of 

a header row in a table, follow these steps: 

1. Go to Table > Insert Table... 

2. In the Insert Table dialog box, provide a name for the table et select the number of rows and 

columns. 

3. In the Options area, check Heading. 

4. Check Repeat heading rows on new pages. 

5. Click Insert. 

 

If a table with these settings is very long, the header row will be repeated on each page, provided that the 

page break(s) are generated automatically, not manually. 

It is also possible to apply the Table Heading style to row and column headers: 

1. Inside the table, select the text you want to turn into headers. 

2. Go to Styles > Styles and Formatting… 

3. In the Styles and Formatting dialog box, open the Table Content group. 

4. Double-click on Table heading. 
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Note: headers must be clear and concise, and on a single line if possible. 

1. Row breaks 
By default, page breaks allow rows to be split and displayed over two pages if they don’t fit in the bottom of 

the first page. But this may compromise the reading of data by users of assistive technologies. 

To ensure that the rows in the table are not broken across pages: 

2. Place the cursor inside the table. 

3. Go to Table > Properties... 

4. Select the Text Flow tab 

5. Uncheck Allow row to break across pages and columns. 

6. Click OK. 

 

 

7. Caption 
A table caption describes the function of the table and how it is organized. All abbreviations used within the 

table must be explained in the caption. 

To insert a caption: 

8. Position the cursor in the table. 

9. Click Insert > Caption…. 

10. In the Caption dialog box, fill in the Caption field, and select the desired properties, then click OK. 
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You can edit the text of a caption directly in the document. 

1. Copying and pasting tables from a LibreOffice Calc sheet 
When inserting a table in LibreOffice Writer from a LibreOffice Calc sheet, it is important to follow these 

guidelines to prevent the table from being pasted as an image and therefore becoming inaccessible to many 

users: 

1. Open the LibreOfficeCalc sheet and select the cells in the table that you want to copy. 

2. Right click and choose Copy. 

3. Switch to the Writer document, then click where you want to insert the table. 

4. Go to Edit > Paste Special.… 

5. In the Paste Special dialog box, in the Selection list, choose HTML (HyperText Markup 

Language) 

6. Click OK. 
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7. Creating navigation aids 

1. Applicable RGAA criteria 
 

Category criteria 

Links 

Criterion 6.1 [A] Is each link explicit (except in particular cases)? 

Criterion 6.2 [A] For each link with a link title, is this title relevant? 

Criterion 6.3 [AAA] Is each link text alone explicit out of context (except in 

particular cases)? 

Criterion 6.4 [A] For each web page, does each identical link have the same 

purpose and target? 

Criterion 6.5 [A] On each Web page, does each link, except in anchors, have 

a text? 

Navigation 
Criterion 12.7 [AA] On each page within a collection of pages, are links 

facilitating navigation available? 

2. Introduction 
A document is not necessarily read in a linear manner. Provided that the document is well structured, with 

proper application of headings, captions, footnotes, etc., a hypertext structure can be generated automatically, 

allowing users to move quickly within the document. 

In addition to the structuring elements described in the previous sections, and tables of contents, of figures or 

of tables, that can be generated automatically, it is possible to enrich the document with navigation elements 

pointing to contents inside and outside the document. 

3. Tables of contents, figures and tables 
A table of contents can be generated automatically from heading styles. 

To insert a table of contents: 

1. Position the cursor at the location where you want to insert a Table of contents. 

2. Go to Insert > Table of Contents and Index > Table of Contents, Index and Bibliography… 

3. Select the Index/Table tab. 

4. In the Type selection list, select Table of contents 

5. Define the table settings (title, index for Chapter or Entire document, etc.) 

6. Confirm with OK. 
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To update the table of contents: 

• Right-click in the Table of contents and choose Update Index. 

• Other option: go to Tools > Update > Indexes and Tables 

It is also possible to generate a table of figures from the image captions, provided that they are correctly 

declared as such. To insert a table of figures from captions: 

1. Position the cursor at the location where you want to insert the table of figures. 

2. Go to Insert > Table of Contents and Index > Table of Contents, Index and Bibliography… 

3. Select the Index/Table tab. 

4. In the Type selection list, select Illustration Index 

5. Define the table settings (title, index for Chapter or Entire document, etc.). By default, the table will 

be created from Captions in the Illustration category. 

6. Confirm with OK. 

4. Bookmarks 
A bookmark is used to identify a location or a selection of text that can be referenced elsewhere in the 

document. Rather than browsing through the document to retrieve the text, the user can easily access the text 

using the Navigator (see Navigator). 

To insert a bookmark: 

1. Select the word or text you want to define as a bookmark. 

2. Go to Insert > Bookmark... 

3. In the Bookmark dialog box, fill in the input field with a bookmark title, and click OK. 
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To reach a bookmark: 

1. Open the Navigator (F5). 

2. Develop the Bookmarks menu. 

3. Double-click on the targeted bookmark. 

5. Cross-references 
Cross-references allow users to directly access to passages of text or objects in a document. Cross-references 

consist of a target and a reference. 

To a create a target for a cross-reference: 

1. Select the text to define as the target. 

2. Go to Insert > Cross-reference 

3. In the Type list, select Set reference 

4. In the Name field, type a name for the target. The selected text appear in the Value field. 

5. Click Insert. 
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To create a reference to an existing target (heading, bookmark, figure, table, etc.): 

1. Place the cursor where you want to insert a cross-reference. 

2. Go to Insert > Cross-reference... 

3. In the Type list, select the category of caption Insert Reference 

4. In the Selection list, select the target for the cross-reference. 

5. In the Insert a Reference To list, select the desired format (the kind of information displayed where 

the reference is inserted). For example, Reference inserts the text of the target, whereas Page inserts 

the page number where the target is. 

6. Click Insert. 
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You can create references to different objects, like pictures, charts, tables, etc., provided they have captions. 

To create a cross-reference to a captioned object: 

1. Place the cursor where you want to insert a cross-reference. 

2. Go to Insert > Cross-reference... 

3. In the Type list, select the category of captions for this object. 

4. In the Selection list, select the caption number corresponding to the targeted object. 

5. In the Insert a Reference To list, select the desired reference format and click Insert. 

6. Links 
Links allow users to navigate within the document, and to external resources where appropriate. Explicit text 

should be used to make links understandable in context, i.e., the sentence or paragraph in which they are 

located. 

To insert and/or edit a link and set its text: 

1. Position the cursor where you wish  to insert and/or edit a link. 
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2. Go to Insert > Hyperlink… 

3. Select the type of link you want to insert (“Internet” for any external link). 

4. In the URL field of the Hyperlink dialog box, enter the target address for the link. 

5. In Further Settings, type the text of the link in the Text field. 

6. Click on Apply and close the dialog box later, or OK 

 

Notes: 

• For external links, inserting a footnote containing the complete link address provides adequate 

information to those who print the document. 

• The hyperlinks in a foreign language must be properly marked, so that speech synthesizers 

pronounce them correctly. 
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8. Creating accessible forms 

1. Applicable RGAA criteria 
 

Category Criteria 

Forms 

Criterion 11.1 [A] Does each form field have a label? 

Criterion 11.2 [A] Is each label associated with a form field relevant? 

Criterion 11.3 [AA] On a given page, or set of pages, all form fields with 

similar functions must have consistent labels. Has this rule been followed? 

Criterion 11.4 [A] In each form, are each label and its related control 

positioned next to each other? 

Criterion 11.5 [A] In each form, is the information of same nature grouped 

together, if necessary? 

Criterion 11.6 [A] In each form, does each form field grouping have a legend? 

Criterion 11.7 [A] In each form, is each legend, related to a form field 

grouping, relevant? 

Criterion 11.8 [A] In each form, is each selection list structured in a relevant 

way? 

Criterion 11.9 [A] In each form, is the text of each button relevant? 

Criterion 11.10 [A] In each form, is the input control used in a relevant way? 

Criterion 11.11 [AA] In each form, is input control accompanied, if necessary, 

by suggestions helping with the correction of input errors? 

Criterion 11.12 [AA] For each form, can financial, legal or personal data be 

changed, updated or retrieved by the user? 

Criterion 11.13 [AAA] For each form, can all data be changed, updated or 

recovered by the user? 

Criterion 11.14 [AAA] For each form, is input assistance available? 

Criterion 11.15 [AAA] For each form, is each input assistance relevant? 

2. Introduction 
A form is an input space, which can have several "fields" where the user can enter text, check boxes, select 

from a list of predefined terms, press buttons, and so on. 

Well-designed forms will be accessible to users of assistive technology, provided they follow a few simple 

rules: 

The focus path (tab order) must be logical and understandable; 

• Each form field must be identified; 

• Form fields must be editable; 

• Information of the same nature should be grouped and labelled clearly; 

• For complex forms, a short description, providing the number of questions or sections, and an 

estimate of the time required to complete the form, may be proposed. 
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LibreOffice Writer includes a tool, the Form Navigator, which allows users to find their way in a form at the 

design phase. 

3. Activating forms design mode 
LibreOffice Writer provides two toolbars that contain the functions required to create and edit a form: the 

Form Controls toolbar and the Form Design toolbar. To activate these menus: 

1. Go to View> Toolbars. 

2. Check Form Controls. 

3. Go to View> Toolbars. 

4. Check Form Design. 

 

To compose the form, the author should write and format the text relating to the form: title of the form, 

questions and explanations. These elements facilitate the understanding and use of the form. 

The Toggle Design Mode button allows to save a form and keep it in Design mode. 

4. Adding form fields 
Once the structure of the form is designed, insert different input areas with content controls (text boxes, 

check boxes, combo boxes, etc.). For each field, you must specify a title and instructional text. 

To add a field, do one of the following operations: 

1. Insert a text box 
1. In the Form Controls floating toolbar, click on Text Box and draw a box with the mouse 

2. Right-click on the box to display a contextual menu. Click the Control... option to open the Control 

Properties dialog box. The options available vary depending on the type of fields. You can change 

the appearance of the field. To make it accessible, make sure to fill in the following fields: 

1. Name: choose a suitable name for the purpose of the field. 
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2. Help text (located at the bottom of the dialog box): will be presented as a tooltip when the user 

hovers over the field with the mouse, and will be output by assistive technologies. 

3. Close the dialog box (there is no validation button, changes are saved by closing). 

 

2. Insert a checkbox 
1. In the Form Controls floating toolbar, click on Check Box and draw a box with the mouse 

2. Right-click on the box to display a contextual menu. Click the Control... option to open the 

Control Properties dialog box. You can change the appearance of the field. To make it accessible, 

make sure to fill in the following fields: 

1. Name: choose a suitable name for the purpose of the field. In this context, “Name” must 

have the same value for all the related check boxes, as to bind them together. 

2. Label: to label the check boxes. 
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3. Help text (located at the bottom of the dialog box): will be presented as a tooltip when the 

user hovers over the field with the mouse, and will be output by assistive technologies. 

3. Close the dialog box (there is no validation button, changes are saved by closing). 

3. Insert a radio buttons group 
1. On the Form Controls floating toolbar, click the List Box icon and draw a box with the 

mouse. Click where you want to insert the text box. 

2. A List Box Wizard dialog box opens 

3. Click Cancel or simply close the box. 

4. Right-click on the box to display a contextual menu. Click the Control... option to open the 

Control Properties dialog box. 

5. In addition to any settings relating to the appearance of the field, the following fields should 

be specified: 

1. Name: choose a suitable name for the purpose of the field. 

2. List entries: click on the black triangle arrow to open the list, and in the input box, type a 

value. Go to next line with Shift + Enter, and repeat. To end the input, press Enter. 

3. Help text (located at the bottom of the dialog box): will be presented as a tooltip when the 

user hovers over the field with the mouse, and will be output by assistive technologies. 

6. Close the dialog box (there is no validation button, changes are saved by closing). 
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When the Design Mode is off, the form will behave like with the users: radio and check boxes can be 

checked, list items can be selected, and so on. Toggle this mode off to test your form. 
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9. Setting document properties 

1. Introduction 
Document properties, also known as metadata, are information about a file that describes or identifies it. 

They include information such as title, author's name, subject, and keywords identifying the topics or content 

of the document. 

When opening a document, some assistive technologies refer to these properties to announce the title of the 

document and to summarize the content. 

These properties are also preserved and used when the document is published in another format. (see 51 

Publishing the document in other formats). 

2. Filling in the document properties 
To view and edit the properties of a document in LibreOffice Writer 5.2 for Windows: 

1. Go to File > Properties... 

2. Under the Description tab, fill in the Title of the document, Keywords, and if appropriate, 

information in the Comments area about its accessibility. 
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51 

1. Publishing the document in other formats 

1. Introduction 
If the techniques described in this guide are used during the creation of an electronic document, this 

document will not only be read by users of assistive technologies for the software used for creation, but its 

semantic composition will also allow for better conversion into other formats, although some adjustments 

may still be necessary depending on the chosen format. 

In this guide, the publication process is described for the following formats: 

• HTML 

• PDF 

Conversion to these formats assumes that documents are properly structured upstream, by following the 

guidelines described in the previous chapters of this guide. 

It is necessary to ensure that the elements related to the accessibility of the document are preserved when 

saving or exporting to other formats. This evaluation work and any corrections due to loss of information or 

conversion errors will not be discussed in detail in this guide. 

2. Publishing in HTML 
LibreOffice Writer allows to publish natively an HTML document. Proceed as follows: 

1. Go to File > Save As... 

2. Choose a name and location for your file. 

3. In the File type list, select HTML Document (Writer). 

4. Click Save. 

5. A message box informs you that some features will not be available if you choose this format. 

Confirm your choice. 
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During export, if properly implemented, most semantic structures will be preserved. However, removal of 

certain useless tags and addition of missing ones will be necessary, using a HTML or text editor. Currently, 

known non-preserved tags are: 

• Cross-references 

• Mathematical formulas (turned into images). 

1. Checking the accessibility of the HTML document 

Open the HTML document in a browser such as Mozilla Firefox and use the HTML test tools to check the 

accessibility of the page. A first quick check verifies: 

1. That the page is structured through HTML heading tags (h1, h2, etc.); 

2. The presence of text alternatives for graphic elements; 

3. That header cells are properly marked up. 

More thorough controls are needed to validate compliance with the RGAA requirements. You may refer to 

the RGAA 3 2016 Testing Methodology4 for detailed instructions. 

3. Export to PDF 
PDF (Portable Document Format) is a format developed by Adobe Systems. It preserves the formatting 

defined by the author, regardless of the application or platform used to read it. 

                                                 
4http://disic.github.io/rgaa_methodologie/en/ 

http://disic.github.io/rgaa_methodologie/en/
http://disic.github.io/rgaa_methodologie/en/
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PDF may contain tags that reflect the document structure. A tree of tags represents the organizational 

structure of the document and allows assistive technologies to determine the presentation and interpretation 

of its content. 

When the techniques described in this guide are followed when creating the document, the conditions are 

optimal for the document to be converted to PDF without loss of structure or information. 

To export to PDF: 

1. Go to File > Save As and choose the location where you want to save your document. 

2. Under the General tag in the PDF Options dialog box, check Tagged PDF. 

3. Under the same tab, check Export bookmarks. 

 

 

4. Under the Initial View tab, in the Pane section, check Bookmarks and Page. 
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5. Click on Export. 

6. Choose a name and a location for your file. 

7. Click on Export. 

1. Accessibility evaluation of a PDF document 
The evaluation of the accessibility of the PDF document requires a screen reading software to check that the 

reading order and restitution of content are correct. To enable the consultation of the document with screen 

reading software, make sure that the permissions are set correctly: 

11. Open the file in Adobe Acrobat and open the File > Properties > Protection menu. 

12. In the Protection method drop-down list, select No protection. 

13. Click OK and close the dialog box. 

If a number of conversion problems can be detected with a screen reader software (reading order, correct 

markup, passages in a foreign language, etc.), the Adobe Acrobat Professional software (paid solution) is 

required to correct possible markup errors. 
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1. Sources 
Authoring Techniques for Accessible Office Documents: OpenOffice Writer (v3.4) and LibreOffice Writer 

(v4.0.4.2)5, Accessible Digital Office Document Project (ADOD), developed by the Inclusive Design 

Research Centre, OCAD University (Ontario, Canada) as part of an EnAbling Change Partnership project 

with the Government of Ontario and UNESCO (United Nations Educational, Scientific and Cultural 

Organization). 

Christophe Strobbe, Creating Accessible Documents with LibreOffice Writer6 [PDF, 831 kb; slides of 

his presentation during the Rencontres Mondiales du Logiciel Libre, Beauvais, France, 5-10 July 2013]. 

WebAIM, Increasing Document Accessibility in OOo Writer7. 

LibreOffice Writer Help8. 

                                                 
5http://adod.idrc.ocad.ca/oowriter 
6https://2015.rmll.info/IMG/pdf/creatingaccessibledocuments_cstrobbe_rmll_2015-07-09.pdf 
7http://webaim.org/techniques/ooo/#writer 
8https://help.libreoffice.org/Writer/Welcome_to_the_Writer_Help 
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http://webaim.org/techniques/ooo/#writer
https://help.libreoffice.org/Writer/Welcome_to_the_Writer_Help
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2. License 
This document is the property of the Secrétariat général à la modernisation de l'action publique (SGMAP). It 

is placed under Open Licence 1.0 or later (PDF, 541 kb)9, equivalent to a Creative Commons BY license. To 

indicate authorship, add a link to the original version of the document available on the DINSIC's GitHub 

account10. 
 

                                                 
9http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf 
10https://github.com/DISIC 

http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf
https://github.com/DISIC
https://github.com/DISIC
http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf
https://github.com/DISIC
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