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1. Introduction 

1. Foreword 
French law n° 2005-102, of 11 February 2005, for equality of rights and opportunities, participation and 

citizenship of people with disabilities, makes accessibility a requirement for all public online communication 

services, for the State, local and regional authorities and the public institutions that depend on them. 

The RGAA (General Accessibility Framework for Administrations) aims to promote accessibility of the 

contents available in digital form. In 2014, the RGAA was redesigned to be up-to-date and more operational. 

The French administrations currently ought to refer to the RGAA 3. 

To meet the needs of diverse groups and contexts, three levels of compliance have been defined: A (lowest), 

AA and AAA. The level legally expected is level double-A (AA). Success criteria associated with the AAA 

level may be taken into account in certain contexts where possible and relevant. 

2. The RGAA and office documents 
The RGAA applies to any document or application available online: websites, Intranet and web applications, 

but also the contents downloadable as separate files. 

In the Consultation category of the RGAA, criterion 13.71 (Level A) states that "each office document that 

can be downloaded [must] have an accessible version if necessary". Compliance with this criterion can be 

achieved in particular by providing an accessible HTML version or by making the document accessible in 

the format proposed for download. 

This companion guide presents the considerations and principles for creating an accessible Excel workbook 

with Microsoft Office 2016, along with non-normative guidance and procedures for implementing them. 

Each chapter is divided into topics and incorporates a reference to the corresponding RGAA criteria. 

Spreadsheet applications have become very powerful tools, with many features, ranging from very simple to 

very complex. With Excel 2016 it is possible to execute a wide range of tasks (data collection, calculation, 

reporting, dashboards creation, data sharing, etc.) that can be as many barriers for people with disabilities. 

This guide deliberately refers only to general principles to make accessible workbooks. 

3. Who is this guide for? 
These guides are intended for all professionals in government departments, local authorities, agencies, public 

institutions, public enterprises or anyone wishing to: 

• Produce accessible office documents; 

• Improve the accessibility of existing office documents; 

• Test the level of accessibility of office documents already created. 

4. Technical devices used to access content 
A document is accessible if it can be accessed by any user, regardless of the computer tool being used. More 

and more users are using assistive technologies to overcome barriers to accessing office workbooks or web 

content. These technical solutions include 

• Software assistive technologies (screen readers, voice recognition / dictation software, etc.); 

• Hardware assistive technologies (adapted mice, trackballs, Braille displays, etc.). 

Content and applications must be compatible with these various assistive technologies, their functionalities 

and uses. 

                                                 
1 URL: https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7 

https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7
https://disic.github.io/rgaa_referentiel_en/criteria.html#crit-13-7
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5. About this translation 
The original document, in French, refers to the Microsoft Office suite in its 2013 version. At the time of 

translation, the current, more easily available version is 2016. This translation takes this fact into account and 

is based on the features of version 2016 where applicable. Consequently, there may be slight variations from 

the original material. 

6. Conventions 
This document indicates keyboard shortcuts for commands used in the Microsoft Office suite. In the 

Windows operating systems family, the CTRL (Control) key is used as a modifier for many shortcuts. In the 

MacOS system, the equivalent modifier key is CMD (Command, represented by the ⌘ symbol). In the rest 

of this document, for clarity, only the Windows shortcut (with CTRL) will be mentioned. Mac users are 

invited to replace it with CMD. 

Texts in bold generally refer to commands and menus available in the user interface. Indications like “File > 

Save” must be understood as “Open the File menu, and then select the Save item in this menu”. 

Mentions like “Right-click on...” actually refer to opening a contextual menu, associated with an item. On 

most systems, this is usually done by clicking on the item with the right button of a mouse or a trackpad. 

Another method, on Windows, consists in pressing the “Menu” key on the keyboard. On MacOS based 

systems, pressing the CTRL key and the left button simultaneously has the same effect. Unfortunately, there 

is no easy way to activate a contextual menu through a keyboard on a Mac. 
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2. How to structure an Excel sheet 

1. Applicable RGAA Criteria 
 

Category Criteria 

Information 

Structure 

Criterion 9.1 [A] On each Web page, is information structured by the 

appropriate use of headings? 

Criterion 9.2 [A] On each Web page, is the document outline coherent? 

Navigation Criterion 12.13 [A] On each Web page, is tabbing order consistent? 

2. Introduction 
Although workbooks are relatively accessible to users of assistive technologies, they are nevertheless a 

complex environment, because the organization of information and their relationships can’t be perceived 

quickly and globally. It is necessary to ensure that the sheets contents are appropriately identified, with 

significant names, and that the structure makes sense. 

3. Inserting data table 
Turning data inside the spreadsheet into data table considerably improves their accessibility to users of 

assistive technologies. 

To define a range of cells as a data table: 

1. Select the cells you want to include to a data table. 

2. Under the Insert tab, in the Tables group, click Table. 

 

 

3. Check the My table has headers box. 

 

 

4. Click OK. 
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The Accessibility Checker embedded in Microsoft Excel recommends to assign a replacement text to every 

data table. However, it is not a RGAA requirement. 

If the workbook contains several data tables, avoid grouping them on one sheet; create a new one for each 

new table. The first sheet can be used as an index describing the workbook contents, with hyperlinks 

pointing to the various tables (see Internal links). 

4. Row and column headers 
The row and column headers indicate the relationship between the data presented. Clear and accurate headers 

are accessible to a wider audience. 

To specify a header row in a cells range, marked as a table with no header: 

1. Click anywhere in the table. 

2. Under the Table Design tab, in the Table Style Options group, select the Header Row check box. 

 

 

3. Add your header info. 

If you do not want to define your data as tables, you can still define row and column headers by attributing 

names to cells (see Naming elements). 

5. Cells organization 
As a general rule, complex spreadsheets cause more accessibility issues. For a better experience for all, 

whenever possible: 

1. Favor a simple structure (for example: headers on only one row); 

2. Avoid merging or splitting cells; 

3. Remove empty cells, generally interpreted as the end of the sheet, or missing input (if needed, fill the 

cell with an explicit mention like “not applicable”, that can have the same text color as the 

background, so that it’s read by assistive technologies only); 

4. Do not use advanced features like locking or hiding cells, freeze panes or filter data. If these are 

deemed necessary, they should be documented to give the opportunity to users to deactivate them. 

6. Floating objects 
In Microsoft Excel 2016 there are no means to link a text area to the cells it refers to; text areas are 

independent from the sheet, and as such, are not perceivable through assistive technologies. 

To insert a comment, use the Comments feature proposed by Excel. When the user moves the cursor to a 

commented cell, the assistive technology will announce the presence of a comment, that the user can choose 

to read or ignore. 

To insert a comment: 

1. Select the cell you want to comment. 
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2. Under the Review tab, in the Comments group, click New Comment. 

 

 

3. Type your comment in the text area. 

 

 

4. Click anywhere outside the comment area. 

To display the comment, place the mouse cursor over the marker in the corner of the cell. 
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3. Using an appropriate presentation 

1. Applicable RGAA Criteria 
 

Category criteria 

Colors 

Criterion 3.1 [A] On each Web page, information must not  be conveyed 

through color only. Has this rule been followed? 

Criterion 3.2 [A] On each Web page, information   must not be conveyed 

through color only. Has this rule been implemented in a relevant way? 

Criterion 3.3 [AA] On each Web page, is the contrast between the text and 

background colors sufficient (except in particular cases)? 

Criterion 3.4 [AAA] On each Web page, is the contrast between the text and 

background colors enhanced (except in particular cases)? 

Mandatory 

Elements 

Criterion 8.9 [A] On each Web page, tags must not be used only for layout. 

Has this rule been followed? 

Presentation 

of information 

Criterion 10.6 [A] On each Web page, can each link whose nature is not 

obvious be distinguished from the surrounding text? 

Criterion 10.12 [AAA] For each Web page, is line and paragraph spacing 

sufficient? 

Criterion 10.13 [A] For each Web page, are hidden texts correctly rendered 

by assistive technologies? 

Criterion 10.15 [A] On each Web page, information must not be conveyed 

by shape, size or location alone. Has this rule been implemented in a 

relevant way? 

2. Introduction 
The visual complexity of a workbook can play a decisive role in understanding its content. If the 

understanding of certain content is conveyed only through color, shape, size or position, with no appropriate 

styling, users of assistive technologies may miss some information. These information can also be a serious 

barrier for users with altered color perception. 

3. Colors 
If information is conveyed only through color, screen reader users (blind or visually impaired users, in 

general) and some color blind people will not be able to access it. Any information conveyed through color 

must therefore also be available via another means, like an explicit text inside a cell, or in a comment (see 

Floating objects). Example: in a tasks list containing cells with a green background for completed 

tasks, and a red one for uncompleted tasks, add mentions like “completed task” and “uncompleted task” after 

the content of the cells. 

The contrast between the background and text colors must also be sufficient to make the reading of the 

workbook comfortable. The RGAA states that the contrast ratio between a non-bold text and its background 

should be 4.5:1 up to 150% of the default font size, and 3:1 beyond. For bold text, a 4.5:1 contrast ratio is 

required up to 120% of the default font size, and 3:1 beyond. This applies to text, graphics and images. 
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A contrast checker is used to determine if colors have sufficient contrasts. The Colour Contrast Analyser2, 

provided by the Paciello Group, can be downloaded free of charge. 

Among others, you may also use this online checker proposed by Tanaguru3. 

4. Fonts 
Whenever possible, some formatting standards should be prioritized to facilitate reading, and make the 

workbooks legible in the main text editors. 

• Standard fonts created for ease of reading: Arial, Calibri, Cambria, Constantia, Garamond, Georgia, 

Helvetica, Times New Roman, Trebuchet MS, and Verdana; 

• Font sizes between 12 and 18 points for the body text; 

• Normal or expanded character spacing, rather than condensed. 

Avoid: 

• Long chunks of text in uppercase, italic or underlined fonts 

• Animated or scrolling text. 

5. Cell Format 
In order to create more legible Excel sheets, it is sometimes necessary to work on its style and layout.  

Borders or background colors, modifications of size or cell format can highlight certain types of contents. In 

order to allow readers to understand the meaning of formatting, it is appropriate to use styles management 

features proposed by Microsoft Excel (title, explanatory text, calculation, comment, etc.) rather than directly 

using character formatting tools. 

To apply predefined styles: 

1. Select the cells you want to apply a style to. 

2. Under the Home tab, in the Styles group, click on Cell Styles. 

 

 

3. Select the style you want to apply in the styles library. 

                                                 
2 https://www.paciellogroup.com/resources/contrastanalyser/ 

3 http://contrast-finder.tanaguru.com/?lang=en 

https://www.paciellogroup.com/resources/contrastanalyser/
http://contrast-finder.tanaguru.com/?lang=en
https://www.paciellogroup.com/resources/contrastanalyser/
http://contrast-finder.tanaguru.com/?lang=en
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To change the characteristics of an existing style: 

1. Select the cells you want to apply a style to. 

2. Under the Home tab, in the Styles group, click on Cell Styles. 
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3. In the styles library, right-click on the style you want to modify, and select Modify… 

 

 

4. In the Styles dialog box, click Format. 
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5. In the Format Cells dialog box, select the desired format under the Alignment, Font, Border and 

Fill tabs, then click OK. 

 

6. Click OK again. 

6. Data format 
The rendering of number-based contents (dates, hours, percentages, currency, etc.) will be more comfortable 

and understandable to users of assistive technologies if theses contents have an appropriate number format. 

To apply an adapted format to your data: 

1. Select the cells to which you want to apply a number format. 
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2. Under the Home tab, in the Number group, click on the listbox and select the appropriate format. 

 

 

To remove or deactivate a number format: 

1. Select the cells for which you want to deactivate a number format. 

2. Under the Home tab, in the Number group, in the Number Format list, select General. 

7. Templates 
The Excel 2016 default template can be used as the basis for accessible workbooks. You can also create your 

own accessible template from an accessible sheet. 

To save a workbook as a template: 

1. Make sure the workbook meets the structuring, presentation, language, description and navigation 

rules proposed in this guide. 

2. Go to File> Save As… 

3. In the list of locations where you can save a workbook, select your local computer 

4. Type a name for your template in the File Name (or Save As) box. 
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5. For a  base template, choose an Excel Template (.xltx) type file in the File Format list. For a 

template that contains macros, select Excel Macro-Enabled Template (.xltm). 

 

 

6. Click Save. 

 

To edit a template, make the desired formatting changes in the file, and then save and close the template. 

To create a new workbook from your custom template, click File > New From Template..., and select the 

desired template. 
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4. Language 

1. Applicable RGAA Criteria 
 

Category criteria 

Mandatory 

elements 

Criterion 8.3 [A] On each Web page, is the default human language 

identifiable? 

Criterion 8.4 [A] For each Web page with a default human language, is the 

language code appropriate? 

Criterion 8.7 [AA] On each Web page, is each change in the human language 

identified via the source code (except in particular cases)? 

Criterion 8.8 [AA] On each Web page, is each change in human language 

relevant? 

Criterion 8.10 [A] On each Web page, are changes in reading direction 

identified? 

Information 

Structure 

Criterion 9.4 [AAA] On each Web page, does the first occurence of each 

abbreviation help to know its meaning? 

Consultation 

Criterion 13.9 [AAA] On each Web page, are unusual expressions, idioms or 

jargon made explicit? 

Criterion 13.10 [AAA] On each Web page, for each expression used in an 

unusual or restricted way, each idiom or jargon with a definition, is this 

definition relevant? 

Criterion 13.13 [AAA] On each Web page, for each word whose meaning 

cannot be understood without knowing the pronunciation, is this 

pronunciation specified? 

Criterion 13.14 [AAA] On each Web page, does each text that requires a 

reading ability more advanced than the lower secondary education level have 

an alternative version? 

2. Introduction 
When the contents of a workbook are clear and accurate, they are easier to consult. To be able to render the 

document properly, assistive technologies need to be aware of the human language used. 

3. Language of the workbook 
The language selected for the workbook determines the dictionary used for spell checking, synonyms and 

hyphenation, as well as a number of formatting rules. For text-to-speech software, it also determines how 

content is spoken. It is therefore imperative to define a language for any workbook. 

To set the language for the workbook: 

1. Go to Tools > Language... 

2. In the section Mark Selected Text As, choose the primary language of the workbook. This setting 

will apply to the whole workbook by default. 

Please note: it is not possible, in Excel 2016, to apply a different language setting for a cell or a range of 

cells. 
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4. Comprehensive language 
Spreadsheets with clear and accurate headers will be accessible to a wider audience. This is also true for 

values in cells and information that identify cells (names, sheet names) and inserted objects (headings, 

alternative texts). 

A few recommendations: 

1. Favor clear and accurate titles and texts. 

2. Provide a name for each sheet (do not leave the default name provided by Excel). 

3. Provide for each sheet a name that differentiates it from the other ones. 
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5. Giving an alternative to non-textual elements 

1. Applicable RGAA criteria 
 

Category criteria 

Images 

Criterion 1.1 [A] Does each image have a text alternative? 

Criterion 1.2 [A] For each decorative image with a text alternative, is this 

alternative empty? 

Criterion 1.3 [A] For each image conveying information with a text 

alternative, is this alternative relevant (except in particular cases)? 

Criterion 1.6 [A] Does each image conveying information have a detailed 

description if necessary? 

Criterion 1.7 [A] For each image conveying information with a detailed 

description, is this description relevant? 

Criterion 1.8 [AA] When an alternate mechanism is missing, each image of 

text conveying information must be replaced with styled text, if possible. 

Has this rule been followed (except in particular cases)? 

Criterion 1.9 [AAA] Each image of text conveying information must be 

replaced with styled text. Has this rule been followed (except in particular 

cases)? 

Criterion 1.10 [A] Is each image caption correctly associated with the 

corresponding image, if necessary? 

Colors 

Criterion 3.1 [A] On each Web page, information must not  be conveyed 

through color only. Has this rule been followed? 

Criterion 3.2 [A] On each Web page, information   must not be conveyed 

through color only. Has this rule been implemented in a relevant way? 

Criterion 3.3 [AA] On each Web page, is the contrast between the text and 

background colors sufficient (except in particular cases)? 

Criterion 3.4 [AAA] On each Web page, is the contrast between the text and 

background colors enhanced (except in particular cases)? 

Consultation 

Criterion 13.11 [A] On each Web page, does each cryptic content (ASCII art, 

emoticon, leetspeak) have an alternative? 

Criterion 13.12 [A] On each Web page, for each cryptic content (ASCII art, 

emoticon, leetspeak) with an alternative, is this alternative relevant? 

Criterion 13.15 [A] On each Web page, are sudden changes in luminosity or 

flashing effects used appropriately? 

Criterion 13.16 [AAA] On each Web page, do the sudden changes in 

luminosity or flashing effects have a frequency lower than or equal to 3 per 

second? 

Criterion 13.17 [A] On each Web page, can each moving or blinking content 

be controlled by the user? 
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Multimedia 

Criterion 4.1 [A] Does each prerecorded time-based media have a text 

transcript or an audio description if necessary (except in particular cases)? 

Criterion 4.2 [A] For each prerecorded time-based media with a text 

transcript or a synchronized audio description, are these relevant (except in 

particular cases)? 

Criterion 4.3 [A] Does each prerecorded synchronized time-based media 

have synchronized captions if necessary (except in particular cases)? 

Criterion 4.4 [A] For each prerecorded synchronized time-based media with 

synchronized captions, are these captions relevant? 

Criterion 4.5 [AA] Does each live time-based media have synchronized 

captions or a text transcript if necessary (except in particular cases)? 

Criterion 4.6 [AA] Are each synchronized captions or text transcript, 

provided for live time-based media, relevant? 

Criterion 4.7 [AA] Does each prerecorded time-based media have a 

synchronized audio description if necessary (except in particular cases)? 

Criterion 4.8 [AA] For each prerecorded time-based media with a 

synchronized audio description, is this audio description relevant? 

Criterion 4.9 [AAA] Does each prerecorded time-based media have a sign 

language interpretation (except in particular cases) if necessary? 

Criterion 4.10 [AAA] For each prerecorded time-based media with a sign 

language interpretation, is this interpretation relevant? 

Criterion 4.11 [AAA] Does each prerecorded time-based media have a 

synchronized extended audio description if necessary (except in particular 

cases)? 

Criterion 4.12 [AAA] For each prerecorded time-based media with a 

synchronized extended audio description, is this audio description relevant? 

Criterion 4.13 [AAA] Does each synchronized or video-only time-based 

media have a text transcript (except in particular cases)? 

Criterion 4.14 [AAA] For each synchronized or video-only time-based 

media with a text transcript, is this text transcript relevant? 

Criterion 4.15 [A] Can each time-based media be clearly identified (except 

in particular cases)? 

Criterion 4.16 [A] Does each non time-based media have, if necessary, an 

alternative (except in particular cases)? 

2. Introduction 
For non-textual elements (images, charts, video and audio files) that convey information not presented as text 

in their proximity, this information must be described in a replacement text, and completed with a 

transcription for video and audio. The replacement text that will be rendered to the reader by assistive 

technologies, when the object gets focus, allowing to understand the purpose of the object, or to become 

aware of the presence of a transcription. Without proper description, these elements can't be perceived by 

assistive technologies. 
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3. Images 
If possible, inserting images inside an Excel spreadsheet should be avoided, because they can cause reading 

issues. 

When inserting an image is necessary, you should ask yourself 3 questions before choosing the text that will 

be rendered in place of the image: 

• Is the image purely decorative, not conveying any information and having no function? 

• Does the item convey information? 

• Does the image have a function (for example, a picture serving as a link)? 

If the image is purely decorative, it should not be assigned alternative text. 

If the image conveys information, it must be associated with a replacement text. This alternative, which also 

serves as a title, must succinctly describe the information conveyed by the image and its meaning in the 

context. 

For an image that serves as a hyperlink, the alternate text must be able to understand the function and the 

destination of the link. The conditions for returning this replacement text require that it be as short as 

possible (a maximum length of 80 characters is strongly recommended). If the information requires a longer 

alternative, a detailed description must be provided. 

A replacement text should not: 

• Include copyright information (for example, for a photo, the name of the copyright holder and the 

date of the picture) 

• Start with "picture of..." or "photo of...". 

To associate an alternative text to an image that conveys information or serves as a hyperlink: 

1. Right-click on the image and select Format Picture... 

2. In the Format Picture pane, Under the Layout & Properties tab, click on Alt Text 

3.  In the Description box, type the alternative text. The Title box must be filled only if the image 

requires a detailed description 

4. Your input is preserved when you switch to another tab or close the pane 
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A detailed description is sometimes necessary when the information conveyed by the image is more 

complex. This requires an interpretation of the image. To insert a detailed description: 

1. Right-click on the image and select Format Picture... 

2. In the Format Picture pane, Under the Layout & Properties tab, click on Alt Text 

3. Fill the Title field with the information essential to understand the purpose of the content. This will 

help the readers decide if they want to proceed with reading the detailed description. 

4. In the Description box, type the detailed description, trying to be as concise and objective as 

possible. 

4. Images of text 
Images of text are images that contain text that is necessary to understand the content of the workbook. It is 

not recommended to use images of texts when it is possible to reproduce the same effects by defining styles 

for "actual" text (see Fonts). 

If the text is part of a logo or an element associated with the graphic identity of an organization or a 

company, it is advisable to propose a textual alternative to the image, while following the recommendations 

above. 

5. Charts 
Spreadsheets are convenient to organize and execute calculation on data, but are not always the best way to 

present them. Visualization as charts makes it generally easier to interpret, and seeing trends and 

relationships. 
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If the needs of users with disability are taken into account by design, charts can be made accessible to all. To 

make their consultation easier, charts should be inserted in separate sheets, with a sheet title that explicitly 

mentions the presence of a chart. 

Fonts, colors and shapes must be chosen with consideration for the needs of color-blind and partially sighted 

readers. Color must not be used alone to convey information. Emphasize the use of dashed line styles to 

improve readability, and, if necessary, replace predefined colors to meet the contrast requirements (see 

Colors). 

To insert a chart: 

1. Select the data you want to include in the chart. 

2. Under the Insert tab, in the Charts group, click on the button corresponding to your needs. 

 

3. Select a type of chart in the chart library. 

Once the chart is created, it should be assigned a title by filling the title field in the chart itself. 

To modify the label format: 

1. Right-click on the axes labels to format, then click on Font… 

2. Under the Font tab, choose the formatting options. 

3. Under the Character spacing tab, choose the spacing options. 

To change the dash type of a shape: 

1. Select the shape you want to modify. 
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2. Under the Format tab, click on the Shape Outline button, then select Dashes, then the type of dash 

you want to apply. 

 

 

To modify the number format on an axis: 

1. Right-click on the axis label and choose Format Axis… 
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2. In the Format Axis pane, Axis Options tab, click on Number 

 

 

3. In the Category drop-down list, choose the desired number format. 

The title and labels of the axes provide necessary elements for the interpretation of the data presented, but 

will not suffice to transmit the specifics of the graphic necessary for its comprehension to someone who fails 

to see it. 

For simple charts, a simple replacement text may suffice. For more complex or detailed charts, it is necessary 

to provided a detailed description. In both cases, it is necessary to avoid listing the raw data as a textual 

alternative, but rather to explain the information that you wish to convey by inserting the chart in the 

workbook. 

To add a replacement text with a detailed description for more complex charts: 

1. Select the entire graph by clicking on the border of the chart (as opposed to a shape or element inside 

the chart). If the Format Data Point pane is already open, it will be replaced by the Format Chart 

Area pane. If not, you will need to right-click on the chart and select Format Chart Area... 

2. In the Format Chart Area pane, click on Chart Options, and select the Layout & Properties tab. 
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3. Fill the Title field with the information essential to understand the purpose of the content. This will 

help the readers decide if they want to proceed with reading the detailed description. 

4. In the Description box, type the detailed description, trying to be as concise and objective as 

possible. 

6.  SmartArt graphics 
All contents of SmartArt graphics (lists, processes, cycles, hierarchies, relationships, matrices, and pyramids, 

and pictures) are available to users navigating through keyboard shortcuts. The choice of colors, fonts and 

shapes must always take into account the needs of colorblind and partially sighted readers, and the 

information should never be conveyed solely by color. 

To insert a SmartArt chart: 

1. Under the Insert tab, in the Illustrations group, click SmartArt. 

 

2. Select the desired type and layout. 

 

3. In the inserted graphic, click on a [Text] area then type in your text. 

To add replacement text to the entire SmartArt graphic, click on the  SmartArt graphic border, right-click on 

it, and follow the instructions in the previous sections. 

7. Multimedia files 
It is possible to insert links to online videos in a Microsoft Excel workbook, but to be played, a media player 

must have been installed on the computer. 
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Note that there are significant differences between Microsoft Windows and MacOS regarding this feature. In 

Microsoft Excel for Mac to insert multimedia objects, go to the Insert menu, and choose Audio or Movie. 

The following instructions apply to Microsoft Windows. 

1. Under the Insert tab, in the Text group, click the Object button. 

 

2. In the dialog box, click Create from File, and then click Browse. 

 

3. Locate the file you want to insert. 

4. Click OK. 

A replacement text must accompany any video or audio clip (see technique described in Images). It is also 

necessary to provide a transcript for any video or audio sequence, and to ensure that the videos include 

closed or open captions (embedded in the video or via an online alternative). 

It is sometimes necessary to propose an audio description, i.e. an additional soundtrack added to the video 

that describes the visual elements: actions, movements, expressions, sets, etc. This audio description must be 

played in blank spaces between the dialogues and the important sound elements. 

The transcript and audio descriptions may be proposed in an annex or in a downloadable file located on a 

distant server, and accessed via a link located close to the object. The  link text must clearly identify the 

proposed audio description or transcription for the media file, because it is technically not possible to 

associate them by other means than wording. 
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The purpose of a transcription is to provide a coherent alternative to multimedia content. Readers must have 

access to all the information conveyed by the video or audio file, including the dialogues between the 

participating protagonists, the location, the main actions and the atmosphere. 
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6. Creating navigation aids 

1. Applicable RGAA criteria 
 

Category criteria 

Links 

Criterion 6.1 [A] Is each link explicit (except in particular cases)? 

Criterion 6.2 [A] For each link with a link title, is this title relevant? 

Criterion 6.3 [AAA] Is each link text alone explicit out of context (except in 

particular cases)? 

Criterion 6.4 [A] For each web page, does each identical link have the same 

purpose and target? 

Criterion 6.5 [A] On each Web page, does each link, except in anchors, have 

a text? 

Navigation 
Criterion 12.7 [AA] On each page within a collection of pages, are links 

facilitating navigation available? 

2. Introduction 
When the contents of a workbook are well identified, they are easier to consult. In addition to the structuring 

elements described in the previous sections, it is possible to enrich the workbook with navigation elements 

pointing to contents inside and outside of it. 

3. Sheets names 
The sheets names, presented as tabs, must be explicit in order to help the users understand the nature of each 

sheet of the workbook. Any empty sheet must be deleted. 

To rename a sheet: 

1. Right-click on its tab, and select Rename. 

2. Enter a short and unique name, that describes the content of the sheet. 

To delete a sheet, right-click on its tab, and select Delete. 

4. Description of the workbook contents 
For workbooks containing complex tables of charts, a short description of the workbook contents, 

mentioning the sheets it contains, can help users to get a global perception of it, and so be more efficient 

when browsing the workbook. 

The first sheet can be dedicated to this description, with links to the sheets composing the workbook (see 

Internal links). Since screen readers users, in Western languages, generally start reading at the first cell 

(A1), if possible, the description should start there. For example: “This workbook contains 2 sheets. The first 

sheet includes a table that starts in A1 and ends in M75, and presents the budget for 2017 [hypertext link to 

the sheet]. The second sheet includes a table a table that starts in A1 and ends in M75, and presents the 

previsional budget for 2017 [hypertext link to the sheet]”. 

Before distributing the workbook, remember to place the cursor in the cell where this description is. 

5. Naming elements 
Excel provides the possibility to name cells, ranges, constants, tables and formulas. When a significant name 

is associated to data, they become more understandable to users of assistive technologies (for example, 

instead of “=(B2+C9)*$D$6, the screen reader will output “Travel_expenses+VAT”). Indeed, some users 

move in the workbook by named elements (the CTRL + G shortcut displays a dialog box listing all the 

names in the workbook, from which the named elements can be reached. Note: this shortcut is the same for 
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Windows and Mac). These named elements can also be referenced elsewhere in the workbook (see 

Internal links). 

Please note: 

• The Mac version of Excel does not provide as many possibilities as the Windows version, with 

regards to names management. The following instructions refer to the Windows version. 

• Naming elements must be done once the workbook is ready to be shared. Any modification (change 

in the sheets order, or addition of a row) requires an update of the names. 

• A name can be specific to a given sheet, or applicable to a whole workbook. 

• A name must always be unique in its own range. 

To insert a name: 

1. If the sheet contains row and column headers, place the cursor at the intersecting cell. 

2. Under the Formulas tab, in the Defined Names group, click on Define Name. 

 

 

3. Assign the name “Title”. 

 

 

4. In the Scope drop-down list, select Workbook or the name of a sheet in the current workbook. 

5. You can enter a descriptive comment in the Comment input area. 

6. In the Refers to text box, do one of the following: 

◦ To enter a cell reference, click on the icon next to the box and select the cell(s) you want to refer 

to. 

◦ To enter a constant, type = (equal sign), followed by the name of the constant. 
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◦ To enter a formula, typ = (equal sign), followed by the formula. 

◦ Click OK. 

If the column contains row titles, use the name “RowTitle” and if the row contains column titles, use the 

name “ColumnTitle”. 

When there are several sheets, repeat the previous steps, but add the sheet number after “Title”, “RowTitle” 

or “ColumnTitle” (e.g. “ColumnTitle4” for the 4th sheet). 

It is possible to define different row or column titles, for different regions, in the same sheet or workbook, by 

adding “Region” to the name: “TitleRegion”, “RowTitleRegion”, or “ColumnTitleRegion”. 

1. Add the region number (e.g. enter “1” if cells are in the 1st region). 

2. Add a dot  followed by the coordinates of the top left cell of the region (e.g. “A1”). 

3. Add a dot  followed by the coordinates of the bottom right cell of the region (e.g. “N9”). 

4. Add a dot followed by the sheet number (e.g. “1” if the cells are in the sheet #1). 

 

To edit a name: 

1. Under the Formulas tab, in the Defined Names group, click on Name Manager. 
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2. Select the name you want to edit, and click on Edit… 

 

 

3. Edit the name and click Close. 

6. Internal links 
It is possible to insert links to named cells or ranges to allow users to navigate within a workbook other than 

from cell to cell. 

To insert a link to a named element: 

1. Position the cursor where you want to insert and / or edit an internal link. 

2. Under the Insert tab, in the Links group, click Hyperlink. 
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3. In the Insert Hyperlink dialog box, click This document. 

 

 

4. In the list of Defined Names, select the named element to which you want to create a link. 

5. In the Text to Display text box, type the name or phrase that briefly describes the destination of the 

link. 

6. To customize the screen tip that appears when you leave the pointer over the hyperlink, click 

ScreenTip..., and then type the required text and click OK. If you do not specify a screen tip, Excel 

uses the name of the named element. 

7. Click OK. 

7. External Links 
Hypertext links can also be used to provide a quick access to information stored in another file or in a web 

page. 

It is recommended to use link texts that make the understandable in their context. 

Position the cursor where you want to insert and / or edit a link. 

1. Under the Insert tab, in the Links group, click Hyperlink. 

2. In the Insert Hyperlink dialog box, click Web Page or File. In the Text to Display text box, type 

the name or phrase that briefly describes the destination of the link. For sheets that are likely to be 

printed, it is preferable to keep the complete address of the link. 

3. In the Address text box, enter the URL of the link. 

4. To complete the information with a screen tip (especially for links displayed as URLs), click 

ScreenTip..., and then type the required text. 
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5. Click OK. 
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7. Creating accessible forms 

1. Applicable RGAA criteria 
 

Category Criteria 

Forms 

Criterion 11.1 [A] Does each form field have a label? 

Criterion 11.2 [A] Is each label associated with a form field relevant? 

Criterion 11.3 [AA] On a given page, or set of pages, all form fields with 

similar functions must have consistent labels. Has this rule been followed? 

Criterion 11.4 [A] In each form, are each label and its related control 

positioned next to each other? 

Criterion 11.5 [A] In each form, is the information of same nature grouped 

together, if necessary? 

Criterion 11.6 [A] In each form, does each form field grouping have a legend? 

Criterion 11.7 [A] In each form, is each legend, related to a form field 

grouping, relevant? 

Criterion 11.8 [A] In each form, is each selection list structured in a relevant 

way? 

Criterion 11.9 [A] In each form, is the text of each button relevant? 

Criterion 11.10 [A] In each form, is the input control used in a relevant way? 

Criterion 11.11 [AA] In each form, is input control accompanied, if necessary, 

by suggestions helping with the correction of input errors? 

Criterion 11.12 [AA] For each form, can financial, legal or personal data be 

changed, updated or retrieved by the user? 

Criterion 11.13 [AAA] For each form, can all data be changed, updated or 

recovered by the user? 

Criterion 11.14 [AAA] For each form, is input assistance available? 

Criterion 11.15 [AAA] For each form, is each input assistance relevant? 

2. Introduction 
A form is an input space, which can have several "fields" where the user can enter text, check boxes, select 

from a list of predefined terms, press buttons, and so on. 

Well-designed forms will be accessible to users of assistive technology, provided they follow a few simple 

rules: 

• The sheet name must indicate the presence of a form in the sheet; 

• The focus path (tab order) must be logical and understandable; 

• Each form field must be identified, with a replacement text; 

• Form fields must be editable; 

• Information of the same nature should be grouped and labelled clearly; 

• For complex forms, a short description, providing the number of questions or sections, and an 

estimate of the time required to complete the form, may be proposed. The first sheet of the workbook 
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can be reserved for this description, with links to the sections of the form (see Internal links) 

Since Western languages screen reader users usually start their navigation in the first cell (A1), this 

description should be placed here. 

To facilitate navigation and a logical flow, the questions and the areas reserved for the answers can be 

arranged in a two-column table with the headers "Questions" and "Answers" (see Row and column 

headers). 

3. Creating a simple form 
When you do not need to use sophisticated features, a simple form of text boxes may be sufficient. The 

format of the cells in the second column can be modified to help the user identify the input fields (see Cell 

Format). 

 

Excel 2016 offers a data validation tool, that improves the accessibility of certain input areas by enabling: 

• the indication of input format; 

• the insertion of drop-down lists; 

• the provision of an input help message when the input field receives focus; 

• the warning of the user when the input format is incorrect. 

 

To set the desired input format: 

1. Select the input field. 

2. Under the Data tab, in the Data Tools group, click on Data Validation.  
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3. Under the Options tab of the Data Validation dialog box, in the Allow drop-down list, select the 

desired format type and complete the settings according to the format. 

 

 

4. Click OK. 

 

To create a drop-down list: 

Select the input field. 

1. Select the input field. 

2. Under the Data tab, in the Data Tools group, click on Data Validation. 

3. Under the Options tab of the Data Validation dialog box, in the Allow drop-down list, select List. 
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4. In the Source box, enter the first value, followed by a comma and a space, and then repeat until the 

list is complete. 

 

 

5. Click OK. 

 

To create an input help which will be displayed as a tooltip and announced when the user makes changes to 

the input field: 

1. Select the input field. 

2. Under the Data tab, in the Data Tools group, click on Data Validation. 
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3. Click on Input Message. 

 

 

4. Ignore the Title field. Enter an instructional text in the Input message box. 

5. Make sure that the “Show input message when cell is selected” check box is selected. 

6. Click OK. 

 

To create an error message: 

1. Select the input field. 

2. Under the Data tab, in the Data Tools group, click on Data Validation. 
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3. Click on Error Alert. 

 

 

4. Select the Style of icon to be displayed (Stop, Warning or Information) and enter the Title of the 

error alert and an Error message that will allow the user to correct the format (explanation and an 

example of correct format, for instance). 

5. Make sure that the “Show error alert after invalid data is entered” is checked. 

6. Click OK. 

 

4. Activating forms design mode 
In order to create and edit forms with controls, it is necessary to display the Developer tab. 

On Windows: 

1. Click the File tab. 

2. Click Options. 

3. Click Customize Ribbon. 

4. Under Customize the Ribbon and under Main Tabs, select the Developer check box. 

On MacOS: 

1. Click the Excel tab. 

2. Click Preferences. 

3. Click Ribbon & Toolbar. 
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4. Under Customize the Ribbon and under Main Tabs, select the Developer check box. 

Before inserting fields, the author should write and format the questions and explanations in the first column. 

1. Adding input areas with controls 
Preliminary note: Microsoft Excel 2016 for Mac does not provide as many options as its counterpart for 

Windows. With the Mac version, form design features are limited to the insertion of the following types: 

Button, Group Box, Combo Box, Label, Check Box, Scroll Bar, List Box, Option Button, Spinner. These 

controls are grouped under the Controls group, under the Developer tab. 

All following instructions describe processes for Microsoft Excel 2016 for Windows. You may adapt them to 

the Mac version as well, but with limitations. 

Once the structure of the form is designed, in the first column, you may insert different input areas with 

content controls (text boxes, check boxes, combo boxes, etc.). For each field, you must specify a title and 

instructional text. 

To insert a form field with control: 

1. Under the Developer tab, in the Controls group, click Insert, and in the ActiveX Controls list, 

select the desired type of input (text area, check box, radio button, drop-down list, etc.). 

2. To title the field, position the cursor on it and under the Developer tab, in the Controls group, click 

Properties and fill the Title field (and other properties as needed), then click OK. 

3. Draw the area on the cell where you want to insert a field. 

4. To create a replacement text that will serve as a help text, right-click on the inserted area, and select 

Format Control… In the Replacement text tab, indicate the nature of expected input. 

2. Inserting buttons 
ActiveX controls allow to insert buttons that can be set to trigger features. These buttons are not accessible to 

assistive technologies. 

Certain features can be triggered through hypertext links. These links can be formatted (borders, background 

color, fonts, etc.) to look like buttons (see Cell Format). 

When it is not possible to activate a feature with a hypertext link, then an alternative method to access this 

feature must be proposed. 



40 

1. Providing additional information 

1. Document properties 
Document properties, also known as metadata, are information about a file that describes or identifies it. 

They include information such as title, author's name, subject, and keywords identifying the topics or content 

of the document. 

When opening a document, some assistive technologies refer to these properties to announce the title of the 

document and to summarize the content. 

These properties are also preserved and used when the document is published in another format. (see 

Publishing the workbook in other formats). 

To view and edit the properties of a workbook in Microsoft Excel 2016 for Windows: 

1. Click File > Info 

2. In the Properties area of the Informations pane, click the property you want to change and update 

it. 

3. Click on the top left arrow to return to the workbook. The changes are saved automatically. 

To view and edit the properties of a workbook in Microsoft Excel 2016 for Mac: 

1. Click File > Properties.... 

2. Click on the tabs on top of the dialog box, to select the type of properties to be edited. 
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10. Checking the accessibility of a Microsoft Excel Workbook 
Microsoft Office 2016 includes an Accessibility Checker. The Accessibility Checker helps identify content 

that may cause reading difficulties for people using assistive technologies. 

The Checker verifies the workbook against the criteria of WCAG 2.0 and the ISO/TS 1607:2003 

specifications, and generates a report that lists three types of issues: 

• Error: a barrier for people with disabilities. 

• Warning: harder to understand for some people with disabilities. 

• Tip: the content could be better organized or presented to optimize the user experience. 

The issues raised may include: 

Errors: 

• No replacement text for any object. 

• Lack of column headers in the data tables. 

Warnings: 

• Unclear link text. 

• Empty table cells. 

• Succession of blank characters. 

• Floating objects. 

Tips: 

• Presence of captions for audio and video. 

To use the Accessibility Checker: 

1. Under the Review tab, in the Workbook group, click Check Accessibility. 

 

2. The Accessibility Checker pane appears on the right side of the window. The results of the 

inspection are classified by type of issue (error, warning and tip) and presented as a hierarchical tree. 

3. Click on a specific issue to see details below the Inspection Results list. The Checker provides 

information on the impact of the issue, and how to fix it. 

4. Selecting the item in the list allows to locate the error in the workbook, in the edition area, easing its 

correction. 
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10. Publishing the workbook in other formats 

1. Introduction 
If the techniques described in this guide are used during the creation of an electronic workbook, this 

workbook will not only be read by users of assistive technologies for the software used for creation, but its 

semantic composition will also allow for better conversion into other formats, although some adjustments 

may still be necessary depending on the chosen format. 

In this guide, the publication process is described for the following formats: 

• HTML 

• PDF 

Conversion to these formats assumes that workbooks are properly structured upstream, by following the 

guidelines described in the previous chapters of this guide. 

It is necessary to ensure that the elements related to the accessibility of the workbook are preserved when 

saving or exporting to other formats. This evaluation work and any corrections due to loss of information or 

conversion errors will not be discussed in detail in this guide. 

2. Publishing in HTML 
All or part of a workbook can be saved in a static web page. When you save a workbook with several active 

sheets, as a HTML page, Excel creates a support folder called “filename_files” (on Windows) or 

"filename.fld" (on MacOS), that contains all the support files for the page. For example, for a file called 

Page1.htm, Excel creates a subfolder named “Page1_files”, or "Page1.fld" (Note: this extension may vary 

with operating system language settings). 

Various saving options are available. The Windows version of Excel offers more options, notably the ability 

to republish the web files when the workbook is saved. The processes are also different. On Windows, click 

on Publish... to proceed; on MacOS, click on Web Options… before saving. The following instructions 

apply to Windows. 

To save as HTML: 

1. Click File > Save As... and choose the location where you want to save your workbook. 

2. Enter a name for your file. 

3. In the File format list, select Web page (*.htm). 

4. To save the whole workbook, including navigation tabs, check the Workbook option. To save the 

active selection in the current sheet, check Selection. 

5. Click on Publish… 

6. In the Publish as a Web page dialog box, select one of the options in the Items to publish list. 

7. To add a title related to the selection, under Publish as, click on Change…, enter a title, and click 

OK. 

8. Click on Browse… next to the File Name box and select the location and name you want for your 

files, then click OK. 

9. If you have activated the AutoRepublish option, a message is displayed each time you save the 

workbook. 

10. To view the Web page in your browser after you save it, select the Open published Web page in 

browser check box. 

11. Click on Publish. 
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If the Web page is copied or moved to another location, the supporting folder must also be moved in order to 

preserve all links in the Web page. 

1. Checking the accessibility of the HTML document 

Open the HTML workbook in a browser such as Mozilla Firefox and use the HTML test tools to check the 

accessibility of the page. A first quick check verifies: 

1. That header cells are properly marked up. 

2. The presence of text alternatives for graphic elements; 

More thorough controls are needed to validate compliance with the RGAA requirements. You may refer to 

the RGAA 3 2016 Testing Methodology4 for detailed instructions. 

3. Export to PDF 
PDF (Portable Document Format) is a format developed by Adobe Systems. It preserves the formatting 

defined by the author, regardless of the application or platform used to read it. 

PDF may contain tags that reflect the workbook structure. A tree of tags represents the organizational 

structure of the workbook and allows assistive technologies to determine the presentation and interpretation 

of its content. 

When the techniques described in this guide are followed when creating the workbook, the conditions are 

optimal for the workbook to be converted to PDF without loss of structure or information. 

Only the Windows version of Excel provides export options for the PDF format. The following instructions 

apply to Windows only. 

To export to PDF: 

1. Click File > Save As and choose the location where you want to save your workbook. 

2. Enter a name for your file. 

3. In the File format list, select PDF (*.pdf). 

4. In the Optimize for section, select the Standard (publishing online and printing) option. 

5. Click Options… to select conversion options. Select the Workbook structure tags for 

accessibility and the ISO 19005-1 compliant (PDF/A) check boxes. 

 

 

                                                 
4http://disic.github.io/rgaa_methodologie/en/ 

http://disic.github.io/rgaa_methodologie/en/
http://disic.github.io/rgaa_methodologie/en/
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6. Click OK, then Save. 

1. Checking the accessibility of a PDF document 
The evaluation of the accessibility of the PDF document requires a screen reading software to check that the 

reading order and restitution of content are correct. To enable the consultation of the workbook with screen 

reading software, make sure that the permissions are set correctly: 

1. Open the file in Adobe Acrobat and open the File > Properties > Protection menu. 

2. In the Protection method drop-down list, select No protection. 

3. Click OK and close the dialog box. 

If a number of conversion problems can be detected with a screen reader software (reading order, correct 

markup, passages in a foreign language, etc.), the Adobe Acrobat Professional software (paid solution) is 

required to correct possible markup errors. 
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11. Sources 
Make your Excel spreadsheets accessible5, Microsoft Office Documentation. 

Authoring Techniques for Accessible Office Documents: Microsoft Excel 20106, Accessible Digital Office 

Document Project (ADOD), developed by the Inclusive Design Research Centre, OCAD University 

(Ontario, Canada) as part of an EnAbling Change Partnership project with the Government of Ontario and 

UNESCO (United Nations Educational, Scientific and Cultural Organization). 

Rendre un tableau Excel accessible avec JAWS, knowledge base of the Programme de certification des 

compétences en accessibilité du Web (PCCAW). Not available on line, at the time of translation. 

Creating accessible Excel worksheets7, RNIB (Word, 192 KB). 

Creating Accessible Microsoft 2010 documents8, Texas Governor's Committee on People with 

Disabilities. 

Microsoft Office online technical support9. 

                                                 
5https://support.office.com/en-us/article/Make-your-Excel-spreadsheets-accessible-6cc05fc5-1314-48b5-8eb3-

683e49b3e593 
6http://adod.idrc.ocad.ca/excel2010 
7http://www.rnib.org.uk/sites/default/files/Creating%20accessible%20Excel%20spreadsheets.docx 
8http://gov.texas.gov/disabilities/accessibledocs 
9https://support.office.com/ 

https://support.office.com/en-us/article/Make-your-Excel-spreadsheets-accessible-6cc05fc5-1314-48b5-8eb3-683e49b3e593
http://adod.idrc.ocad.ca/excel2010
http://www.rnib.org.uk/sites/default/files/Creating%20accessible%20Excel%20spreadsheets.docx
http://gov.texas.gov/disabilities/accessibledocs
https://support.office.com/
https://support.office.com/en-us/article/Make-your-Excel-spreadsheets-accessible-6cc05fc5-1314-48b5-8eb3-683e49b3e593
https://support.office.com/en-us/article/Make-your-Excel-spreadsheets-accessible-6cc05fc5-1314-48b5-8eb3-683e49b3e593
http://adod.idrc.ocad.ca/excel2010
http://www.rnib.org.uk/sites/default/files/Creating%20accessible%20Excel%20spreadsheets.docx
http://gov.texas.gov/disabilities/accessibledocs
https://support.office.com/
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12. License 
This document is the property of the Secrétariat général à la modernisation de l'action publique (SGMAP). It 

is placed under Open Licence 1.0 or later (PDF, 541 kb)10, equivalent to a Creative Commons BY license. To 

indicate authorship, add a link to the original version of the document available on the DINSIC's GitHub 

account11. 

 

                                                 
10http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf 
11https://github.com/DISIC 

http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf
https://github.com/DISIC
https://github.com/DISIC
http://ddata.over-blog.com/xxxyyy/4/37/99/26/licence/Licence-Ouverte-Open-Licence-ENG.pdf
https://github.com/DISIC
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